aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Event-Sunrise/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-07-06 12:29:28 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-07-06 12:29:28 +0000
commit60c045fec76f110662b174ca14f08174736e3f3b (patch)
treef2191e0f5c5283c03c6fd14197c6b3727bed00c8 /devel/p5-DateTime-Event-Sunrise/Makefile
parentcb53888e9bb7aad727b2cb87959d4f7deea3a4ae (diff)
Notes
Diffstat (limited to 'devel/p5-DateTime-Event-Sunrise/Makefile')
-rw-r--r--devel/p5-DateTime-Event-Sunrise/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/p5-DateTime-Event-Sunrise/Makefile b/devel/p5-DateTime-Event-Sunrise/Makefile
new file mode 100644
index 000000000000..9bbd47735df4
--- /dev/null
+++ b/devel/p5-DateTime-Event-Sunrise/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-DateTime-Event-Sunrise
+# Date created: 2 july 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Event-Sunrise
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= DateTime Objects for sunrise and sunset for a given day
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/DateTime/Set.pm:${PORTSDIR}/devel/p5-DateTime-Set
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Event::Sunrise.3
+
+.include <bsd.port.pre.mk>
+
+# Depends on p5-DateTime-Set which requires perl >= 5.6
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 and try again
+.endif
+
+.include <bsd.port.post.mk>