aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Fiscal-Year
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-10-03 17:18:04 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-10-03 17:18:04 +0000
commit5e6b4937a7e951abb2337dad591ef0b062304d5a (patch)
tree507aa1d8138eb21f2c4868b0427981b984bc1942 /devel/p5-DateTime-Fiscal-Year
parent80ad08f1140ff4c0fca42a49fbef3786f1892589 (diff)
Notes
Diffstat (limited to 'devel/p5-DateTime-Fiscal-Year')
-rw-r--r--devel/p5-DateTime-Fiscal-Year/Makefile26
-rw-r--r--devel/p5-DateTime-Fiscal-Year/distinfo1
-rw-r--r--devel/p5-DateTime-Fiscal-Year/pkg-descr9
-rw-r--r--devel/p5-DateTime-Fiscal-Year/pkg-plist3
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/p5-DateTime-Fiscal-Year/Makefile b/devel/p5-DateTime-Fiscal-Year/Makefile
new file mode 100644
index 000000000000..8a0f49b576e5
--- /dev/null
+++ b/devel/p5-DateTime-Fiscal-Year/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-DateTime-Fiscal-Year
+# Date created: 3 october 2003
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Fiscal-Year
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Calculate the day or week of the Fiscal Year with an arbitrary start date
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Fiscal::Year.3
+
+.include "../../devel/p5-Module-Build/inc.build.mk"
+.include <bsd.port.mk>
diff --git a/devel/p5-DateTime-Fiscal-Year/distinfo b/devel/p5-DateTime-Fiscal-Year/distinfo
new file mode 100644
index 000000000000..c8987d947f99
--- /dev/null
+++ b/devel/p5-DateTime-Fiscal-Year/distinfo
@@ -0,0 +1 @@
+MD5 (DateTime-Fiscal-Year-0.02.tar.gz) = 6d574822bbcd87fc67518966bcd1fb7a
diff --git a/devel/p5-DateTime-Fiscal-Year/pkg-descr b/devel/p5-DateTime-Fiscal-Year/pkg-descr
new file mode 100644
index 000000000000..b27a48eb8a6f
--- /dev/null
+++ b/devel/p5-DateTime-Fiscal-Year/pkg-descr
@@ -0,0 +1,9 @@
+This module allows you to calulate the day, week, period or quarter of a date
+in a fiscal year, given a start date and either a target date or number of
+periods and target date. This is often needed in business, where the fiscal
+year begins and ends on different days than the calendar year. This module is
+based on the Gregorian calendar. Using other DT calendar objects will return
+results, but the behavior is unpredicatable for calendars that have more than
+365 or 366 days.
+
+WWW: http://datetime.perl.org/
diff --git a/devel/p5-DateTime-Fiscal-Year/pkg-plist b/devel/p5-DateTime-Fiscal-Year/pkg-plist
new file mode 100644
index 000000000000..987c386cd5b7
--- /dev/null
+++ b/devel/p5-DateTime-Fiscal-Year/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/DateTime/Fiscal/Year.pm
+@dirrm %%SITE_PERL%%/DateTime/Fiscal 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime 2>/dev/null || true