aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Format-Builder
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-07-06 12:59:25 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-07-06 12:59:25 +0000
commit100b0774fea8ab4b0f5eae2f73aba0f7a274fcba (patch)
tree95bb0fcd5c84a46ec35e07623ee0f4a856973586 /devel/p5-DateTime-Format-Builder
parent89e9641a419a5dfa13c8e65308721a08b12f5de9 (diff)
downloadports-100b0774fea8ab4b0f5eae2f73aba0f7a274fcba.tar.gz
ports-100b0774fea8ab4b0f5eae2f73aba0f7a274fcba.zip
Notes
Diffstat (limited to 'devel/p5-DateTime-Format-Builder')
-rw-r--r--devel/p5-DateTime-Format-Builder/Makefile41
-rw-r--r--devel/p5-DateTime-Format-Builder/distinfo1
-rw-r--r--devel/p5-DateTime-Format-Builder/pkg-descr11
-rw-r--r--devel/p5-DateTime-Format-Builder/pkg-plist14
4 files changed, 67 insertions, 0 deletions
diff --git a/devel/p5-DateTime-Format-Builder/Makefile b/devel/p5-DateTime-Format-Builder/Makefile
new file mode 100644
index 000000000000..9f45986c8c13
--- /dev/null
+++ b/devel/p5-DateTime-Format-Builder/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: p5-DateTime-Format-Builder
+# Date created: 2 july 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Format-Builder
+PORTVERSION= 0.75
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Create DateTime parser classes and objects
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ ${SITE_PERL}/File/Find/Rule.pm:${PORTSDIR}/devel/p5-File-Find-Rule \
+ ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
+ ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/DateTime/Format/Strptime.pm:${PORTSDIR}/devel/p5-DateTime-Format-Strptime
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Format::Builder.3 DateTime::Format::Builder::Parser.3 \
+ DateTime::Format::Builder::Parser::Dispatch.3 \
+ DateTime::Format::Builder::Parser::Regex.3 \
+ DateTime::Format::Builder::Parser::Strptime.3 \
+ DateTime::Format::Builder::Parser::generic.3 \
+ DateTime::Format::Builder::Tutorial.3 \
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} <= 500600
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-DateTime-Format-Builder/distinfo b/devel/p5-DateTime-Format-Builder/distinfo
new file mode 100644
index 000000000000..7a7766465f7e
--- /dev/null
+++ b/devel/p5-DateTime-Format-Builder/distinfo
@@ -0,0 +1 @@
+MD5 (DateTime-Format-Builder-0.75.tar.gz) = f795ed288332d71ea2001b964533ee00
diff --git a/devel/p5-DateTime-Format-Builder/pkg-descr b/devel/p5-DateTime-Format-Builder/pkg-descr
new file mode 100644
index 000000000000..08eadb73a35c
--- /dev/null
+++ b/devel/p5-DateTime-Format-Builder/pkg-descr
@@ -0,0 +1,11 @@
+DateTime::Format::Builder creates DateTime parsers. Many string formats of
+dates and times are simple and just require a basic regular expression to
+extract the relevant information. Builder provides a simple way to do this
+without writing reams of structural code.
+
+Builder provides a number of methods, most of which you'll never need, or at
+least rarely need. They're provided more for exposing of the module's innards
+to any subclasses, or for when you need to do something slightly beyond what I
+expected.
+
+WWW: http://datetime.perl.org/
diff --git a/devel/p5-DateTime-Format-Builder/pkg-plist b/devel/p5-DateTime-Format-Builder/pkg-plist
new file mode 100644
index 000000000000..00263864160c
--- /dev/null
+++ b/devel/p5-DateTime-Format-Builder/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/DateTime/Format/Builder.pm
+%%SITE_PERL%%/DateTime/Format/Builder.pod
+%%SITE_PERL%%/DateTime/Format/Builder/Parser.pm
+%%SITE_PERL%%/DateTime/Format/Builder/Parser/Dispatch.pm
+%%SITE_PERL%%/DateTime/Format/Builder/Parser/Regex.pm
+%%SITE_PERL%%/DateTime/Format/Builder/Parser/Strptime.pm
+%%SITE_PERL%%/DateTime/Format/Builder/Parser/generic.pm
+%%SITE_PERL%%/DateTime/Format/Builder/Tutorial.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime-Format-Builder/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime-Format-Builder
+@dirrm %%SITE_PERL%%/DateTime/Format/Builder/Parser
+@dirrm %%SITE_PERL%%/DateTime/Format/Builder
+@unexec rmdir %D/%%SITE_PERL%%/DateTime/Format 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime 2>/dev/null || true