aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Format-Duration/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-01-08 14:21:02 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-01-08 14:21:02 +0000
commitacb31dcb24519c4bc39abbd29f16934f68a592dc (patch)
tree357e3f5839de8403f3f194fed0ba8f7ba78b9b89 /devel/p5-DateTime-Format-Duration/Makefile
parentd24ed08726879316038ef19ed5c98f44026a457c (diff)
Notes
Diffstat (limited to 'devel/p5-DateTime-Format-Duration/Makefile')
-rw-r--r--devel/p5-DateTime-Format-Duration/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/p5-DateTime-Format-Duration/Makefile b/devel/p5-DateTime-Format-Duration/Makefile
new file mode 100644
index 000000000000..9e3431a61945
--- /dev/null
+++ b/devel/p5-DateTime-Format-Duration/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-DateTime-Format-Duration
+# Date created: 8 Jan 2004
+# Whom: Mathieu Arnold <mat@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Format-Duration
+PORTVERSION= 1.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Format and parse DateTime::Durations
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Format::Duration.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our (\S+)/use vars qw($$1); $$1/' ${WRKSRC}/lib/DateTime/Format/Duration.pm
+.endif
+
+.include <bsd.port.post.mk>