aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Format-Duration
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-01-08 14:21:02 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-01-08 14:21:02 +0000
commitacb31dcb24519c4bc39abbd29f16934f68a592dc (patch)
tree357e3f5839de8403f3f194fed0ba8f7ba78b9b89 /devel/p5-DateTime-Format-Duration
parentd24ed08726879316038ef19ed5c98f44026a457c (diff)
downloadports-acb31dcb24519c4bc39abbd29f16934f68a592dc.tar.gz
ports-acb31dcb24519c4bc39abbd29f16934f68a592dc.zip
Notes
Diffstat (limited to 'devel/p5-DateTime-Format-Duration')
-rw-r--r--devel/p5-DateTime-Format-Duration/Makefile32
-rw-r--r--devel/p5-DateTime-Format-Duration/distinfo1
-rw-r--r--devel/p5-DateTime-Format-Duration/pkg-descr4
-rw-r--r--devel/p5-DateTime-Format-Duration/pkg-plist7
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/p5-DateTime-Format-Duration/Makefile b/devel/p5-DateTime-Format-Duration/Makefile
new file mode 100644
index 000000000000..9e3431a61945
--- /dev/null
+++ b/devel/p5-DateTime-Format-Duration/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-DateTime-Format-Duration
+# Date created: 8 Jan 2004
+# Whom: Mathieu Arnold <mat@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Format-Duration
+PORTVERSION= 1.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Format and parse DateTime::Durations
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Format::Duration.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our (\S+)/use vars qw($$1); $$1/' ${WRKSRC}/lib/DateTime/Format/Duration.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-DateTime-Format-Duration/distinfo b/devel/p5-DateTime-Format-Duration/distinfo
new file mode 100644
index 000000000000..36364cbe986a
--- /dev/null
+++ b/devel/p5-DateTime-Format-Duration/distinfo
@@ -0,0 +1 @@
+MD5 (DateTime-Format-Duration-1.01.tar.gz) = c4216a988ead7381b5fd6ac3b00683d8
diff --git a/devel/p5-DateTime-Format-Duration/pkg-descr b/devel/p5-DateTime-Format-Duration/pkg-descr
new file mode 100644
index 000000000000..c4d274c1d54f
--- /dev/null
+++ b/devel/p5-DateTime-Format-Duration/pkg-descr
@@ -0,0 +1,4 @@
+This module formats and parses DateTime::Duration objects as well as other
+durations representations.
+
+WWW: http://datetime.perl.org/
diff --git a/devel/p5-DateTime-Format-Duration/pkg-plist b/devel/p5-DateTime-Format-Duration/pkg-plist
new file mode 100644
index 000000000000..2ea6f3a459ae
--- /dev/null
+++ b/devel/p5-DateTime-Format-Duration/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/DateTime/Format/Duration.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format/Duration/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format/Duration
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime/Format 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime 2>/dev/null || true