aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Format-Epoch
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-07-07 09:11:36 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-07-07 09:11:36 +0000
commit7cffe7e9610b07c8e7a901fafdbf2dc5d9f1059c (patch)
treea22d02cd7e5d5750bea641562aab8519b62cc8cf /devel/p5-DateTime-Format-Epoch
parentaa61ef57a9b57381f906261ed5a7d5f35afad042 (diff)
downloadports-7cffe7e9610b07c8e7a901fafdbf2dc5d9f1059c.tar.gz
ports-7cffe7e9610b07c8e7a901fafdbf2dc5d9f1059c.zip
Notes
Diffstat (limited to 'devel/p5-DateTime-Format-Epoch')
-rw-r--r--devel/p5-DateTime-Format-Epoch/Makefile27
-rw-r--r--devel/p5-DateTime-Format-Epoch/distinfo1
-rw-r--r--devel/p5-DateTime-Format-Epoch/pkg-descr5
-rw-r--r--devel/p5-DateTime-Format-Epoch/pkg-plist11
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/p5-DateTime-Format-Epoch/Makefile b/devel/p5-DateTime-Format-Epoch/Makefile
new file mode 100644
index 000000000000..21420c7b61eb
--- /dev/null
+++ b/devel/p5-DateTime-Format-Epoch/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-DateTime-Format-Epoch
+# Date created: 2 july 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Format-Epoch
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Convert DateTimes to/from epoch seconds
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/Math/BigInt.pm:${PORTSDIR}/math/p5-Math-BigInt
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Format::Epoch.3 DateTime::Format::Epoch::MacOS.3 \
+ DateTime::Format::Epoch::TAI64.3 DateTime::Format::Epoch::Unix.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-DateTime-Format-Epoch/distinfo b/devel/p5-DateTime-Format-Epoch/distinfo
new file mode 100644
index 000000000000..d8e8e914b761
--- /dev/null
+++ b/devel/p5-DateTime-Format-Epoch/distinfo
@@ -0,0 +1 @@
+MD5 (DateTime-Format-Epoch-0.04.tar.gz) = ead98127a9e3478049f1e8fdcb8a6037
diff --git a/devel/p5-DateTime-Format-Epoch/pkg-descr b/devel/p5-DateTime-Format-Epoch/pkg-descr
new file mode 100644
index 000000000000..9df8f1ad4fb2
--- /dev/null
+++ b/devel/p5-DateTime-Format-Epoch/pkg-descr
@@ -0,0 +1,5 @@
+This module can convert a DateTime object (or any object that can be converted
+to a DateTime object) to the number of seconds since a given epoch. It can also
+do the reverse.
+
+WWW: http://datetime.perl.org/
diff --git a/devel/p5-DateTime-Format-Epoch/pkg-plist b/devel/p5-DateTime-Format-Epoch/pkg-plist
new file mode 100644
index 000000000000..32c0c4ff8b3c
--- /dev/null
+++ b/devel/p5-DateTime-Format-Epoch/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/DateTime/Format/Epoch.pm
+%%SITE_PERL%%/DateTime/Format/Epoch/MacOS.pm
+%%SITE_PERL%%/DateTime/Format/Epoch/TAI64.pm
+%%SITE_PERL%%/DateTime/Format/Epoch/Unix.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format/Epoch/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format/Epoch
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime 2>/dev/null || true
+@dirrm %%SITE_PERL%%/DateTime/Format/Epoch
+@unexec rmdir %D/%%SITE_PERL%%/DateTime/Format 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime 2>/dev/null || true