aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Format-IBeat/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-10-03 17:02:55 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-10-03 17:02:55 +0000
commit80ad08f1140ff4c0fca42a49fbef3786f1892589 (patch)
treee701458d359c13090fc2108d9af1252af03d13db /devel/p5-DateTime-Format-IBeat/Makefile
parentd6c018dbe5dfdcc60c65c2818039f47432b20744 (diff)
downloadports-80ad08f1140ff4c0fca42a49fbef3786f1892589.tar.gz
ports-80ad08f1140ff4c0fca42a49fbef3786f1892589.zip
Notes
Diffstat (limited to 'devel/p5-DateTime-Format-IBeat/Makefile')
-rw-r--r--devel/p5-DateTime-Format-IBeat/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/p5-DateTime-Format-IBeat/Makefile b/devel/p5-DateTime-Format-IBeat/Makefile
new file mode 100644
index 000000000000..d339d9f81f8d
--- /dev/null
+++ b/devel/p5-DateTime-Format-IBeat/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-DateTime-Format-IBeat
+# Date created: 3 october 2003
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Format-IBeat
+PORTVERSION= 0.15
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Format times in .beat notation
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Format::IBeat.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+post-patch:
+ @${PERL} -pi -e '$$_ = "" if (/use 5.006|use warnings/);' \
+ -e 's/^our ([^\s;]+)/use vars qw($$1); $$1/;' \
+ -e 's/\$$dt->\$$_/$$&()/g;' \
+ ${WRKSRC}/lib/DateTime/Format/IBeat.pm
+.endif
+
+.include <bsd.port.post.mk>