aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Format-ICal/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-07-08 08:47:40 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-07-08 08:47:40 +0000
commit8e364a3ebd448931210ba2e37d986d3457862e04 (patch)
treeb756897c068b8c585b7a356b1657429824ba7e1f /devel/p5-DateTime-Format-ICal/Makefile
parent76a7fd06ee406ec5afed368a826ae3e541a61a20 (diff)
Notes
Diffstat (limited to 'devel/p5-DateTime-Format-ICal/Makefile')
-rw-r--r--devel/p5-DateTime-Format-ICal/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/p5-DateTime-Format-ICal/Makefile b/devel/p5-DateTime-Format-ICal/Makefile
new file mode 100644
index 000000000000..905ec9eb746e
--- /dev/null
+++ b/devel/p5-DateTime-Format-ICal/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-DateTime-Format-ICal
+# Date created: 2 july 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Format-ICal
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Parse and format ICal datetime and duration strings
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/DateTime/TimeZone.pm:${PORTSDIR}/devel/p5-DateTime-TimeZone \
+ ${SITE_PERL}/DateTime/Event/ICal.pm:${PORTSDIR}/devel/p5-DateTime-Event-ICal \
+ ${SITE_PERL}/DateTime/Span.pm:${PORTSDIR}/devel/p5-DateTime-Set \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+# Depends on devel/p5-DateTime-Event-ICal which requires perl >= 5.6
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>