aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Format-SQLite
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-06-28 01:58:30 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-06-28 01:58:30 +0000
commit6317da651a981132e89238da750daf5edb50552f (patch)
tree456264e9256d6e49601fc9602688d85b4514255e /devel/p5-DateTime-Format-SQLite
parente6f825a0480e6b72bc3f04a7d2d5ad3baa7ef222 (diff)
downloadports-6317da651a981132e89238da750daf5edb50552f.tar.gz
ports-6317da651a981132e89238da750daf5edb50552f.zip
Notes
Diffstat (limited to 'devel/p5-DateTime-Format-SQLite')
-rw-r--r--devel/p5-DateTime-Format-SQLite/Makefile24
-rw-r--r--devel/p5-DateTime-Format-SQLite/distinfo3
-rw-r--r--devel/p5-DateTime-Format-SQLite/pkg-descr6
-rw-r--r--devel/p5-DateTime-Format-SQLite/pkg-plist7
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/p5-DateTime-Format-SQLite/Makefile b/devel/p5-DateTime-Format-SQLite/Makefile
new file mode 100644
index 000000000000..9bf7eae2f411
--- /dev/null
+++ b/devel/p5-DateTime-Format-SQLite/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-DateTime-Format-SQLite
+# Date created: 23 june 2009
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Format-SQLite
+PORTVERSION= 0.10
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= Parse and format SQLite dates and times
+
+BUILD_DEPENDS= ${SITE_PERL}/DateTime/Format/Builder.pm:${PORTSDIR}/devel/p5-DateTime-Format-Builder
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Format::SQLite.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-DateTime-Format-SQLite/distinfo b/devel/p5-DateTime-Format-SQLite/distinfo
new file mode 100644
index 000000000000..c8e4325daeb6
--- /dev/null
+++ b/devel/p5-DateTime-Format-SQLite/distinfo
@@ -0,0 +1,3 @@
+MD5 (DateTime-Format-SQLite-0.10.tar.gz) = 93c0849d25498028f18e10816b9b32b8
+SHA256 (DateTime-Format-SQLite-0.10.tar.gz) = 674bcc71559d6ebd480a4c087ddcc658c1b2912a6ef7c783f7292a39be8b945b
+SIZE (DateTime-Format-SQLite-0.10.tar.gz) = 12942
diff --git a/devel/p5-DateTime-Format-SQLite/pkg-descr b/devel/p5-DateTime-Format-SQLite/pkg-descr
new file mode 100644
index 000000000000..f5f880bc1f14
--- /dev/null
+++ b/devel/p5-DateTime-Format-SQLite/pkg-descr
@@ -0,0 +1,6 @@
+This module understands the formats used by SQLite for its DATE, DATETIME, TIME,
+and TIMESTAMP data types. It can be used to parse these formats in order to
+create DateTime objects, and it can take a DateTime object and produce a string
+representing it in the SQLite format.
+
+WWW: http://search.cpan.org/dist/DateTime-Format-SQLite/
diff --git a/devel/p5-DateTime-Format-SQLite/pkg-plist b/devel/p5-DateTime-Format-SQLite/pkg-plist
new file mode 100644
index 000000000000..a569d06eec6f
--- /dev/null
+++ b/devel/p5-DateTime-Format-SQLite/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format/SQLite/.packlist
+%%SITE_PERL%%/DateTime/Format/SQLite.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format/SQLite
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime
+@dirrmtry %%SITE_PERL%%/DateTime/Format
+@dirrmtry %%SITE_PERL%%/DateTime