aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Functions/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-01-08 14:52:05 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-01-08 14:52:05 +0000
commit4faf7fde4da3bf4c9e99c6a52f9314377b3acb6b (patch)
treefff365e36e2cfc057743ed4ec12236cbf2774fb1 /devel/p5-DateTime-Functions/Makefile
parentccfd55b3455cba439cc760a7c487868191a00506 (diff)
Notes
Diffstat (limited to 'devel/p5-DateTime-Functions/Makefile')
-rw-r--r--devel/p5-DateTime-Functions/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/p5-DateTime-Functions/Makefile b/devel/p5-DateTime-Functions/Makefile
new file mode 100644
index 000000000000..9882bb47380d
--- /dev/null
+++ b/devel/p5-DateTime-Functions/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-DateTime-Functions
+# Date created: 8 Jan 2004
+# Whom: Mathieu Arnold <mat@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Functions
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Procedural interface to DateTime functions
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Functions.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e '$$_ = "" if /use 5.0/' ${WRKSRC}/Makefile.PL
+.endif
+
+.include <bsd.port.post.mk>