aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Incomplete
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-11-05 13:17:18 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-11-05 13:17:18 +0000
commit4a102e1d329a8d4917a829e27518d709e4aadb30 (patch)
tree7d2d346238327cd975e5c3f0931d5efee7307407 /devel/p5-DateTime-Incomplete
parent7a3024fb9218f355e61fc738a3fd965fabcdb19b (diff)
downloadports-4a102e1d329a8d4917a829e27518d709e4aadb30.tar.gz
ports-4a102e1d329a8d4917a829e27518d709e4aadb30.zip
Notes
Diffstat (limited to 'devel/p5-DateTime-Incomplete')
-rw-r--r--devel/p5-DateTime-Incomplete/Makefile28
-rw-r--r--devel/p5-DateTime-Incomplete/distinfo1
-rw-r--r--devel/p5-DateTime-Incomplete/pkg-descr6
-rw-r--r--devel/p5-DateTime-Incomplete/pkg-plist5
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/p5-DateTime-Incomplete/Makefile b/devel/p5-DateTime-Incomplete/Makefile
new file mode 100644
index 000000000000..f2f8236f4b55
--- /dev/null
+++ b/devel/p5-DateTime-Incomplete/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-DateTime-Incomplete
+# Date created: 5 november 2003
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Incomplete
+PORTVERSION= 0.01.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.(..)$/\1/}
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= An incomplete DateTime, like January 5
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/DateTime/Set.pm:${PORTSDIR}/devel/p5-DateTime-Set \
+ ${SITE_PERL}/DateTime/Event/Recurrence.pm:${PORTSDIR}/devel/p5-DateTime-Event-Recurrence
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Incomplete.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-DateTime-Incomplete/distinfo b/devel/p5-DateTime-Incomplete/distinfo
new file mode 100644
index 000000000000..76863a84ce09
--- /dev/null
+++ b/devel/p5-DateTime-Incomplete/distinfo
@@ -0,0 +1 @@
+MD5 (DateTime-Incomplete-0.0101.tar.gz) = 55070893532228149f1a0d5c67e7f6ac
diff --git a/devel/p5-DateTime-Incomplete/pkg-descr b/devel/p5-DateTime-Incomplete/pkg-descr
new file mode 100644
index 000000000000..52dd254b3077
--- /dev/null
+++ b/devel/p5-DateTime-Incomplete/pkg-descr
@@ -0,0 +1,6 @@
+DateTime::Incomplete is a class for representing partial dates and times.
+
+These are actually encountered relatively frequently. For example, a birthday
+is commonly given as a month and day, without a year.
+
+WWW: http://datetime.perl.org/
diff --git a/devel/p5-DateTime-Incomplete/pkg-plist b/devel/p5-DateTime-Incomplete/pkg-plist
new file mode 100644
index 000000000000..8956387dc87e
--- /dev/null
+++ b/devel/p5-DateTime-Incomplete/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/DateTime/Incomplete.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Incomplete/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Incomplete
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime 2>/dev/null || true