aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Util-Calc
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-06-17 08:13:39 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-06-17 08:13:39 +0000
commit77fbb7c312d467779d54e2eea01b436afafc250c (patch)
tree6441737ddc2d2fca5829586e20719745b14dc7c6 /devel/p5-DateTime-Util-Calc
parent733c9c6a00fd706f6b4ba8db7b7972a420b4c71d (diff)
downloadports-77fbb7c312d467779d54e2eea01b436afafc250c.tar.gz
ports-77fbb7c312d467779d54e2eea01b436afafc250c.zip
Notes
Diffstat (limited to 'devel/p5-DateTime-Util-Calc')
-rw-r--r--devel/p5-DateTime-Util-Calc/Makefile34
-rw-r--r--devel/p5-DateTime-Util-Calc/distinfo3
-rw-r--r--devel/p5-DateTime-Util-Calc/pkg-descr4
-rw-r--r--devel/p5-DateTime-Util-Calc/pkg-plist8
4 files changed, 49 insertions, 0 deletions
diff --git a/devel/p5-DateTime-Util-Calc/Makefile b/devel/p5-DateTime-Util-Calc/Makefile
new file mode 100644
index 000000000000..11790128810f
--- /dev/null
+++ b/devel/p5-DateTime-Util-Calc/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-DateTime-Util-Calc
+# Date created: 2007-06-16
+# Whom: Masahiro Teramoto <markun@onohara.to>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Util-Calc
+PORTVERSION= 0.13002
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= markun@onohara.to
+COMMENT= DateTime Calculation Utilities
+
+BUILD_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-Math-BigInt>=0:${PORTSDIR}/math/p5-Math-BigInt
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Util::Calc.3
+
+OPTIONS= GMP "Use GMP library" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GMP)
+BUILD_DEPENDS+= p5-Math-BigInt-GMP>=0:${PORTSDIR}/math/p5-Math-BigInt-GMP
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-DateTime-Util-Calc/distinfo b/devel/p5-DateTime-Util-Calc/distinfo
new file mode 100644
index 000000000000..6ac0327dba84
--- /dev/null
+++ b/devel/p5-DateTime-Util-Calc/distinfo
@@ -0,0 +1,3 @@
+MD5 (DateTime-Util-Calc-0.13002.tar.gz) = 5d289484b093d43fa29efbe97c5f2e53
+SHA256 (DateTime-Util-Calc-0.13002.tar.gz) = e12184868c13c85dc4390f9e553ab36b03a7713108a12c27e2f3de69dcc2cc9a
+SIZE (DateTime-Util-Calc-0.13002.tar.gz) = 25601
diff --git a/devel/p5-DateTime-Util-Calc/pkg-descr b/devel/p5-DateTime-Util-Calc/pkg-descr
new file mode 100644
index 000000000000..4b8ee824d709
--- /dev/null
+++ b/devel/p5-DateTime-Util-Calc/pkg-descr
@@ -0,0 +1,4 @@
+This module contains some common calculation utilities
+that are required to perform datetime calculations.
+
+WWW: http://search.cpan.org/dist/DateTime-Util-Calc/
diff --git a/devel/p5-DateTime-Util-Calc/pkg-plist b/devel/p5-DateTime-Util-Calc/pkg-plist
new file mode 100644
index 000000000000..dffb3116ebdf
--- /dev/null
+++ b/devel/p5-DateTime-Util-Calc/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Util/Calc/.packlist
+%%SITE_PERL%%/DateTime/Util/Calc.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Util/Calc
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Util
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime
+@dirrmtry %%SITE_PERL%%/DateTime/Util/Calc
+@dirrmtry %%SITE_PERL%%/DateTime/Util
+@dirrmtry %%SITE_PERL%%/DateTime