aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-06-07 10:08:40 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-06-07 10:08:40 +0000
commitbdfc8ddc434bd827d89c8a142e58c5bd3987da64 (patch)
tree1c535a183359a68104b3b572e0e9bb9ac8f2e28f /devel/p5-DateTime/Makefile
parent7d3d6a2f1c18721251a38a545f19b3f9114461ab (diff)
downloadports-bdfc8ddc434bd827d89c8a142e58c5bd3987da64.tar.gz
ports-bdfc8ddc434bd827d89c8a142e58c5bd3987da64.zip
Notes
Diffstat (limited to 'devel/p5-DateTime/Makefile')
-rw-r--r--devel/p5-DateTime/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/p5-DateTime/Makefile b/devel/p5-DateTime/Makefile
new file mode 100644
index 000000000000..476da26404f7
--- /dev/null
+++ b/devel/p5-DateTime/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-DateTime
+# Date created: 4 mai 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime
+PORTVERSION= 0.11
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= A date and time object
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Factory/Util.pm:${PORTSDIR}/devel/p5-Class-Factory-Util \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ ${SITE_PERL}/DateTime/LeapSecond.pm:${PORTSDIR}/devel/p5-DateTime-LeapSecond \
+ ${SITE_PERL}/DateTime/TimeZone.pm:${PORTSDIR}/devel/p5-DateTime-TimeZone
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime.3 DateTime::Duration.3 \
+ DateTime::Infinite.3 DateTime::Language.3
+
+.include <bsd.port.mk>