aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Devel-REPL
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-02 17:23:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-02 17:23:30 +0000
commita65606c10e76919adc28771510fc5161888dbeb5 (patch)
tree8e0dd88960f26157e837a903756b4e1eb2116348 /devel/p5-Devel-REPL
parentcaab476be83664064b855d5f1c7edc4c6d22419a (diff)
downloadports-a65606c10e76919adc28771510fc5161888dbeb5.tar.gz
ports-a65606c10e76919adc28771510fc5161888dbeb5.zip
Notes
Diffstat (limited to 'devel/p5-Devel-REPL')
-rw-r--r--devel/p5-Devel-REPL/Makefile67
-rw-r--r--devel/p5-Devel-REPL/distinfo3
-rw-r--r--devel/p5-Devel-REPL/pkg-descr11
-rw-r--r--devel/p5-Devel-REPL/pkg-plist48
4 files changed, 129 insertions, 0 deletions
diff --git a/devel/p5-Devel-REPL/Makefile b/devel/p5-Devel-REPL/Makefile
new file mode 100644
index 000000000000..545f18dd52f2
--- /dev/null
+++ b/devel/p5-Devel-REPL/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: p5-Devel-REPL
+# Date created: 2009-08-31
+# Whom: Ashish SHUKLA <wahjava@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Devel-REPL
+PORTVERSION= 1.003007
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wahjava@gmail.com
+COMMENT= A modern perl interactive shell
+
+BUILD_DEPENDS= p5-Moose>=0.74:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-Object-Pluggable>=0.0009:${PORTSDIR}/devel/p5-MooseX-Object-Pluggable \
+ p5-MooseX-Getopt>=0.18:${PORTSDIR}/devel/p5-MooseX-Getopt \
+ p5-MooseX-AttributeHelpers>=0.21:${PORTSDIR}/devel/p5-MooseX-AttributeHelpers \
+ p5-namespace-clean>0:${PORTSDIR}/devel/p5-namespace-clean \
+ p5-File-HomeDir>0:${PORTSDIR}/devel/p5-File-HomeDir \
+ p5-Task-Weaken>0:${PORTSDIR}/devel/p5-Task-Weaken \
+ p5-PPI>0:${PORTSDIR}/textproc/p5-PPI \
+ p5-Data-Dump-Streamer>0:${PORTSDIR}/devel/p5-Data-Dump-Streamer \
+ p5-File-Next>0:${PORTSDIR}/sysutils/p5-File-Next \
+ p5-B-Keywords>0:${PORTSDIR}/devel/p5-B-Keywords \
+ p5-Lexical-Persistence>0:${PORTSDIR}/devel/p5-Lexical-Persistence \
+ p5-App-Nopaste>0:${PORTSDIR}/www/p5-App-Nopaste \
+ p5-Module-Refresh>0:${PORTSDIR}/devel/p5-Module-Refresh
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= 5.8.1+
+
+MAN3= Devel::REPL.3 \
+ Devel::REPL::Plugin::B::Concise.3 \
+ Devel::REPL::Plugin::Colors.3 \
+ Devel::REPL::Plugin::Commands.3 \
+ Devel::REPL::Plugin::Completion.3 \
+ Devel::REPL::Plugin::CompletionDriver::Globals.3 \
+ Devel::REPL::Plugin::CompletionDriver::INC.3 \
+ Devel::REPL::Plugin::CompletionDriver::Keywords.3 \
+ Devel::REPL::Plugin::CompletionDriver::LexEnv.3 \
+ Devel::REPL::Plugin::CompletionDriver::Methods.3 \
+ Devel::REPL::Plugin::CompletionDriver::Turtles.3 \
+ Devel::REPL::Plugin::DDS.3 \
+ Devel::REPL::Plugin::DumpHistory.3 \
+ Devel::REPL::Plugin::FancyPrompt.3 \
+ Devel::REPL::Plugin::FindVariable.3 \
+ Devel::REPL::Plugin::History.3 \
+ Devel::REPL::Plugin::Interrupt.3 \
+ Devel::REPL::Plugin::LexEnv.3 \
+ Devel::REPL::Plugin::MultiLine::PPI.3 \
+ Devel::REPL::Plugin::NewlineHack.3 \
+ Devel::REPL::Plugin::Nopaste.3 \
+ Devel::REPL::Plugin::OutputCache.3 \
+ Devel::REPL::Plugin::PPI.3 \
+ Devel::REPL::Plugin::Packages.3 \
+ Devel::REPL::Plugin::Peek.3 \
+ Devel::REPL::Plugin::ReadLineHistory.3 \
+ Devel::REPL::Plugin::Refresh.3 \
+ Devel::REPL::Plugin::ShowClass.3 \
+ Devel::REPL::Plugin::Timing.3 \
+ Devel::REPL::Plugin::Turtles.3 \
+ Devel::REPL::Profile.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Devel-REPL/distinfo b/devel/p5-Devel-REPL/distinfo
new file mode 100644
index 000000000000..55756c63dd0b
--- /dev/null
+++ b/devel/p5-Devel-REPL/distinfo
@@ -0,0 +1,3 @@
+MD5 (Devel-REPL-1.003007.tar.gz) = 2feec7e574161c6551532295585857ab
+SHA256 (Devel-REPL-1.003007.tar.gz) = 56960821b0342233253d15648a9420c29b01e97b127a76190d2ec05ee020e1b4
+SIZE (Devel-REPL-1.003007.tar.gz) = 44082
diff --git a/devel/p5-Devel-REPL/pkg-descr b/devel/p5-Devel-REPL/pkg-descr
new file mode 100644
index 000000000000..14af51dae0a4
--- /dev/null
+++ b/devel/p5-Devel-REPL/pkg-descr
@@ -0,0 +1,11 @@
+This is an interactive shell for Perl, commonly known as a REPL -
+Read, Evaluate, Print, Loop. The shell provides for rapid development
+or testing of code without the need to create a temporary source code
+file.
+
+Through a plugin system, many features are available on demand. You
+can also tailor the environment through the use of profiles and run
+control files, for example to pre-load certain Perl modules when
+working on a particular project.
+
+WWW: http://search.cpan.org/dist/Devel-REPL/
diff --git a/devel/p5-Devel-REPL/pkg-plist b/devel/p5-Devel-REPL/pkg-plist
new file mode 100644
index 000000000000..6d821c8392d2
--- /dev/null
+++ b/devel/p5-Devel-REPL/pkg-plist
@@ -0,0 +1,48 @@
+bin/re.pl
+%%SITE_PERL%%/Devel/REPL.pm
+%%SITE_PERL%%/Devel/REPL/Error.pm
+%%SITE_PERL%%/Devel/REPL/Meta/Plugin.pm
+%%SITE_PERL%%/Devel/REPL/Plugin.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/B/Concise.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/Colors.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/Commands.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/Completion.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/CompletionDriver/Globals.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/CompletionDriver/INC.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/CompletionDriver/Keywords.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/CompletionDriver/LexEnv.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/CompletionDriver/Methods.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/CompletionDriver/Turtles.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/DDS.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/DumpHistory.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/FancyPrompt.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/FindVariable.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/History.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/Interrupt.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/LexEnv.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/MultiLine/PPI.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/NewlineHack.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/Nopaste.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/OutputCache.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/PPI.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/Packages.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/Peek.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/ReadLineHistory.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/Refresh.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/ShowClass.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/Timing.pm
+%%SITE_PERL%%/Devel/REPL/Plugin/Turtles.pm
+%%SITE_PERL%%/Devel/REPL/Profile.pm
+%%SITE_PERL%%/Devel/REPL/Profile/Default.pm
+%%SITE_PERL%%/Devel/REPL/Script.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel/REPL/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel/REPL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel
+@dirrmtry %%SITE_PERL%%/Devel/REPL/Profile
+@dirrmtry %%SITE_PERL%%/Devel/REPL/Plugin/MultiLine
+@dirrmtry %%SITE_PERL%%/Devel/REPL/Plugin/CompletionDriver
+@dirrmtry %%SITE_PERL%%/Devel/REPL/Plugin/B
+@dirrmtry %%SITE_PERL%%/Devel/REPL/Plugin
+@dirrmtry %%SITE_PERL%%/Devel/REPL/Meta
+@dirrmtry %%SITE_PERL%%/Devel/REPL
+@dirrmtry %%SITE_PERL%%/Devel