aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Devel-Size-Report/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2009-11-05 07:55:23 +0000
committerWen Heping <wen@FreeBSD.org>2009-11-05 07:55:23 +0000
commite9f01a4f9900e2d80c3d949346f1d90dc66f74a3 (patch)
tree5dbcedc45050260440db8ab85585fb254ef3299a /devel/p5-Devel-Size-Report/Makefile
parent2705c1f43ff64def112119e0194ee408eb2d5f1f (diff)
Notes
Diffstat (limited to 'devel/p5-Devel-Size-Report/Makefile')
-rw-r--r--devel/p5-Devel-Size-Report/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/p5-Devel-Size-Report/Makefile b/devel/p5-Devel-Size-Report/Makefile
new file mode 100644
index 000000000000..9a247c62a70f
--- /dev/null
+++ b/devel/p5-Devel-Size-Report/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Devel-Size-Report
+# Date created: Wed 04 Nov 2009
+# Whom: Alexey V. Degtyarev
+#
+# $FreeBSD$
+#
+
+PORTNAME= Devel-Size-Report
+PORTVERSION= 0.13
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= Extension to generate a size report for all elements in a structure
+
+BUILD_DEPENDS= p5-Array-RefElem>=1.00:${PORTSDIR}/misc/p5-Array-RefElem \
+ p5-Devel-Size>=0.69:${PORTSDIR}/devel/p5-Devel-Size \
+ p5-Scalar-List-Utils>=1.13:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Time-HiRes>=1.86:${PORTSDIR}/devel/p5-Time-HiRes
+
+PERL_CONFIGURE= yes
+
+MAN3= Devel::Size::Report.3
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= CHANGES
+
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+.include <bsd.port.mk>