aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Devel-StealthDebug
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-08-19 14:17:35 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-08-19 14:17:35 +0000
commitbb9d4889656e09558f1b503cf8d4889ff8701e7a (patch)
tree0b602ff43da24ba8ab2c68da86d4f25dae33e665 /devel/p5-Devel-StealthDebug
parent6ade5dd247b2fc45b8d6c68db50f2d39a7dfcea4 (diff)
downloadports-bb9d4889656e09558f1b503cf8d4889ff8701e7a.tar.gz
ports-bb9d4889656e09558f1b503cf8d4889ff8701e7a.zip
Notes
Diffstat (limited to 'devel/p5-Devel-StealthDebug')
-rw-r--r--devel/p5-Devel-StealthDebug/Makefile33
-rw-r--r--devel/p5-Devel-StealthDebug/distinfo2
-rw-r--r--devel/p5-Devel-StealthDebug/pkg-descr17
-rw-r--r--devel/p5-Devel-StealthDebug/pkg-plist5
4 files changed, 57 insertions, 0 deletions
diff --git a/devel/p5-Devel-StealthDebug/Makefile b/devel/p5-Devel-StealthDebug/Makefile
new file mode 100644
index 000000000000..409f29067172
--- /dev/null
+++ b/devel/p5-Devel-StealthDebug/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Devel-StealthDebug
+# Date created: August 18th 2004
+# Whom: Alex Kapranoff <alex@kapranoff.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Devel-StealthDebug
+PORTVERSION= 1.008
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Devel
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Simple non-intrusive debug module
+
+BUILD_DEPENDS= ${SITE_PERL}/Filter/Simple.pm:${PORTSDIR}/textproc/p5-Filter-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+INSTALL_TARGET= pure_install
+
+MAN3= Devel::StealthDebug.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our (\S+)/use vars qw($$1); $$1/' ${WRKSRC}/StealthDebug.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Devel-StealthDebug/distinfo b/devel/p5-Devel-StealthDebug/distinfo
new file mode 100644
index 000000000000..66e2e31d06bb
--- /dev/null
+++ b/devel/p5-Devel-StealthDebug/distinfo
@@ -0,0 +1,2 @@
+MD5 (Devel-StealthDebug-1.008.tar.gz) = 9ef33916d1a4270b704c7c521feb39e8
+SIZE (Devel-StealthDebug-1.008.tar.gz) = 10417
diff --git a/devel/p5-Devel-StealthDebug/pkg-descr b/devel/p5-Devel-StealthDebug/pkg-descr
new file mode 100644
index 000000000000..b4a561ba0f12
--- /dev/null
+++ b/devel/p5-Devel-StealthDebug/pkg-descr
@@ -0,0 +1,17 @@
+This module lets you add debugging instructions which look
+like comments and do nothing unless you 'use' this module.
+
+ use Devel::StealthDebug;
+
+ my $foo = 0;
+ # ... Several processing on $foo
+
+ my $bar = 1 / $foo; #!assert($foo != 0)!
+
+ my %myhash; #!watch(%myhash)!
+
+ sub func1 { #!emit(Entering func1)!
+ #...
+ }
+
+WWW: http://search.cpan.org/dist/Devel-StealthDebug/
diff --git a/devel/p5-Devel-StealthDebug/pkg-plist b/devel/p5-Devel-StealthDebug/pkg-plist
new file mode 100644
index 000000000000..c5c26f50e175
--- /dev/null
+++ b/devel/p5-Devel-StealthDebug/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel/StealthDebug/.packlist
+%%SITE_PERL%%/Devel/StealthDebug.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel/StealthDebug
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Devel 2>/dev/null || true