aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DynaLoader-Functions
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-02-08 05:15:02 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-02-08 05:15:02 +0000
commit68c1486e94c650f0cf6f1db5a45038f8cca5081b (patch)
tree46abe59577e183865a14a7a2dc3c95ab8d15f4ca /devel/p5-DynaLoader-Functions
parent7fab964151472f1332527c0b1b71079c46885e7f (diff)
downloadports-68c1486e94c650f0cf6f1db5a45038f8cca5081b.tar.gz
ports-68c1486e94c650f0cf6f1db5a45038f8cca5081b.zip
Notes
Diffstat (limited to 'devel/p5-DynaLoader-Functions')
-rw-r--r--devel/p5-DynaLoader-Functions/Makefile31
-rw-r--r--devel/p5-DynaLoader-Functions/distinfo2
-rw-r--r--devel/p5-DynaLoader-Functions/pkg-descr6
-rw-r--r--devel/p5-DynaLoader-Functions/pkg-plist5
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/p5-DynaLoader-Functions/Makefile b/devel/p5-DynaLoader-Functions/Makefile
new file mode 100644
index 000000000000..44ab16fa28aa
--- /dev/null
+++ b/devel/p5-DynaLoader-Functions/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-DynaLoader-Functions
+# Date created: 2012-02-07
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DynaLoader-Functions
+PORTVERSION= 0.001
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Deconstructed dynamic C library loading
+
+TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
+
+PERL_CONFIGURE= yes
+
+MAN3= DynaLoader::Functions.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-DynaLoader-Functions/distinfo b/devel/p5-DynaLoader-Functions/distinfo
new file mode 100644
index 000000000000..3f9a53f05139
--- /dev/null
+++ b/devel/p5-DynaLoader-Functions/distinfo
@@ -0,0 +1,2 @@
+SHA256 (DynaLoader-Functions-0.001.tar.gz) = 4fff7fb35e5dc3d1f947277d548393f4c23c59190b68e8553ed800615ff76570
+SIZE (DynaLoader-Functions-0.001.tar.gz) = 9572
diff --git a/devel/p5-DynaLoader-Functions/pkg-descr b/devel/p5-DynaLoader-Functions/pkg-descr
new file mode 100644
index 000000000000..93c1f6c430a6
--- /dev/null
+++ b/devel/p5-DynaLoader-Functions/pkg-descr
@@ -0,0 +1,6 @@
+DynaLoader::Functions provides a function-based interface to dynamic loading as
+used by Perl. Some details of dynamic loading are very platform-dependent, so
+correct use of these functions requires the programmer to be mindful of the
+space of platform variations.
+
+WWW: http://search.cpan.org/dist/DynaLoader-Functions/
diff --git a/devel/p5-DynaLoader-Functions/pkg-plist b/devel/p5-DynaLoader-Functions/pkg-plist
new file mode 100644
index 000000000000..f6d7076d3823
--- /dev/null
+++ b/devel/p5-DynaLoader-Functions/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/DynaLoader/Functions.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DynaLoader/Functions/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DynaLoader/Functions
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DynaLoader
+@dirrmtry %%SITE_PERL%%/DynaLoader