aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Eval-Context
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2008-04-22 15:26:32 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2008-04-22 15:26:32 +0000
commit39ea63ff4976de884bc492ac251fcd9481b28cb1 (patch)
treeeab63c22d356e68428c721511079d60f84a005e0 /devel/p5-Eval-Context
parentb5f41d2e8654acabe43bb399378df107a9ba1bf6 (diff)
Notes
Diffstat (limited to 'devel/p5-Eval-Context')
-rw-r--r--devel/p5-Eval-Context/Makefile39
-rw-r--r--devel/p5-Eval-Context/distinfo3
-rw-r--r--devel/p5-Eval-Context/pkg-descr7
-rw-r--r--devel/p5-Eval-Context/pkg-plist2
4 files changed, 51 insertions, 0 deletions
diff --git a/devel/p5-Eval-Context/Makefile b/devel/p5-Eval-Context/Makefile
new file mode 100644
index 000000000000..1c04117fd6a7
--- /dev/null
+++ b/devel/p5-Eval-Context/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: p5-Eval-Context
+# Date Created: 22 Apr 2008
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Eval-Context
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= http://cpan.mirror.solnet.ch/authors/id/N/NK/NKH/ \
+ CRITICAL
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Evalute perl code in context wraper
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Output.pm:${PORTSDIR}/devel/p5-Test-Output \
+ ${SITE_PERL}/Package/Generator.pm:${PORTSDIR}/devel/p5-Package-Generator \
+ ${SITE_PERL}/Test/Spelling.pm:${PORTSDIR}/devel/p5-Test-Spelling \
+ ${SITE_PERL}/Test/Block.pm:${PORTSDIR}/devel/p5-Test-Block \
+ ${SITE_PERL}/Test/NoWarnings.pm:${PORTSDIR}/devel/p5-Test-NoWarnings \
+ ${SITE_PERL}/Test/Distribution.pm:${PORTSDIR}/devel/p5-Test-Distribution \
+ ${SITE_PERL}/Test/Warn.pm:${PORTSDIR}/devel/p5-Test-Warn \
+ ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
+ ${SITE_PERL}/Test/Dependencies.pm:${PORTSDIR}/devel/p5-Test-Dependencies \
+ ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version \
+ ${SITE_PERL}/Test/Strict.pm:${PORTSDIR}/devel/p5-Test-Strict \
+ ${SITE_PERL}/Directory/Scratch/Structured.pm:${PORTSDIR}/devel/p5-Directory-Scratch-Structured \
+ ${SITE_PERL}/Data/TreeDumper.pm:${PORTSDIR}/devel/p5-Data-TreeDumper \
+ ${SITE_PERL}/Data/Compare.pm:${PORTSDIR}/devel/p5-Data-Compare \
+ ${SITE_PERL}/File/Slurp.pm:${PORTSDIR}/devel/p5-File-Slurp
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Eval::Context.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Eval-Context/distinfo b/devel/p5-Eval-Context/distinfo
new file mode 100644
index 000000000000..a6ca15d9c521
--- /dev/null
+++ b/devel/p5-Eval-Context/distinfo
@@ -0,0 +1,3 @@
+MD5 (Eval-Context-0.06.tar.gz) = 3a898b0019ffc6861ad9e43c25da90c3
+SHA256 (Eval-Context-0.06.tar.gz) = 8ad88473b2c8654bce4735bb7df30538facb2eef09229ead59034e631d033023
+SIZE (Eval-Context-0.06.tar.gz) = 24463
diff --git a/devel/p5-Eval-Context/pkg-descr b/devel/p5-Eval-Context/pkg-descr
new file mode 100644
index 000000000000..6664255d2e50
--- /dev/null
+++ b/devel/p5-Eval-Context/pkg-descr
@@ -0,0 +1,7 @@
+This module define a subroutine that let you evaluate Perl code in a specific
+context. The code can be passed directly as a string or as a file name to read
+from. It also provides some subroutines to let you define and optionally share
+variables and subroutines between your code and the code you wish to evaluate.
+Finally there is some support for running your code in a safe compartment.
+
+WWW: http://search.cpan.org/dist/Eval-Context/
diff --git a/devel/p5-Eval-Context/pkg-plist b/devel/p5-Eval-Context/pkg-plist
new file mode 100644
index 000000000000..d37d622c2930
--- /dev/null
+++ b/devel/p5-Eval-Context/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Eval/Context.pm
+@dirrmtry %%SITE_PERL%%/Eval