aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Event-Lib
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-06-08 01:29:52 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-06-08 01:29:52 +0000
commit8f643afd4ea1b4ed5c9523b228d66ebe5a891f2b (patch)
tree6ea939eb90de9a63bfa7caff9e7e874ec21d92b4 /devel/p5-Event-Lib
parent027b392c6f0c7940c0500f975b5109159ec88629 (diff)
downloadports-8f643afd4ea1b4ed5c9523b228d66ebe5a891f2b.tar.gz
ports-8f643afd4ea1b4ed5c9523b228d66ebe5a891f2b.zip
Notes
Diffstat (limited to 'devel/p5-Event-Lib')
-rw-r--r--devel/p5-Event-Lib/Makefile30
-rw-r--r--devel/p5-Event-Lib/distinfo3
-rw-r--r--devel/p5-Event-Lib/files/patch-Makefile.PL15
-rw-r--r--devel/p5-Event-Lib/pkg-descr6
-rw-r--r--devel/p5-Event-Lib/pkg-plist8
5 files changed, 62 insertions, 0 deletions
diff --git a/devel/p5-Event-Lib/Makefile b/devel/p5-Event-Lib/Makefile
new file mode 100644
index 000000000000..1af7690c90dc
--- /dev/null
+++ b/devel/p5-Event-Lib/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: Event-Lib
+# Date created: 07 Jun 2006
+# Whom: Fabian Keil <fk@fabiankeil.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Event-Lib
+PORTVERSION= 1.00
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Event
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fk@fabiankeil.de
+COMMENT= Makes libevent(3) accessible with Perl
+
+LIB_DEPENDS= event-1.1a:${PORTSDIR}/devel/libevent
+
+PERL_CONFIGURE= yes
+
+MAN3= Event::Lib.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Event-Lib/distinfo b/devel/p5-Event-Lib/distinfo
new file mode 100644
index 000000000000..703efd4fcd92
--- /dev/null
+++ b/devel/p5-Event-Lib/distinfo
@@ -0,0 +1,3 @@
+MD5 (Event-Lib-1.00.tar.gz) = 354d8705c791afc0d4128e278e22ca14
+SHA256 (Event-Lib-1.00.tar.gz) = 4276c23ea1ad7f7ffc6997770e09fbdc837e3b514a056b8ab90d6209490fbcd6
+SIZE (Event-Lib-1.00.tar.gz) = 46325
diff --git a/devel/p5-Event-Lib/files/patch-Makefile.PL b/devel/p5-Event-Lib/files/patch-Makefile.PL
new file mode 100644
index 000000000000..5e42b40e1975
--- /dev/null
+++ b/devel/p5-Event-Lib/files/patch-Makefile.PL
@@ -0,0 +1,15 @@
+--- Makefile.PL.orig Tue Mar 7 08:37:40 2006
++++ Makefile.PL Mon Jun 5 23:31:13 2006
+@@ -2,7 +2,11 @@
+ use ExtUtils::MakeMaker;
+ use Config;
+
+-my %args = map { split /\s*=\s*/ } @ARGV;
++my %args;
++foreach $_ (@ARGV){
++ m/(.*?)=(.*)/;
++ $args{$1} = $2;
++}
+
+ # purge @ARGV of CCFLAGS
+
diff --git a/devel/p5-Event-Lib/pkg-descr b/devel/p5-Event-Lib/pkg-descr
new file mode 100644
index 000000000000..664681267449
--- /dev/null
+++ b/devel/p5-Event-Lib/pkg-descr
@@ -0,0 +1,6 @@
+Event-Lib is a Perl wrapper around libevent(3)
+(http://www.monkey.org/~provos/libevent/).
+It makes the handling of asynchronous events more comfortable.
+
+WWW: http://search.cpan.org/dist/Event-Lib/
+Author: Tassilo von Parseval <tassilo.von.parseval at rwth-aachen dot de>
diff --git a/devel/p5-Event-Lib/pkg-plist b/devel/p5-Event-Lib/pkg-plist
new file mode 100644
index 000000000000..f85cc35e2dff
--- /dev/null
+++ b/devel/p5-Event-Lib/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Event/Lib.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Event/Lib/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Event/Lib/Lib.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Event/Lib/Lib.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Event/Lib
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Event
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Event