aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Exception-Handler
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-26 20:00:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-26 20:00:38 +0000
commit380cda1a2b90dfb6ebbe55f3308ef3c06fbeaabf (patch)
tree17191cc940fcc346c23dd152f34b9b68441abb74 /devel/p5-Exception-Handler
parenta9b87338761b2e086f9211d464180c88430970c5 (diff)
downloadports-380cda1a2b90dfb6ebbe55f3308ef3c06fbeaabf.tar.gz
ports-380cda1a2b90dfb6ebbe55f3308ef3c06fbeaabf.zip
Notes
Diffstat (limited to 'devel/p5-Exception-Handler')
-rw-r--r--devel/p5-Exception-Handler/Makefile23
-rw-r--r--devel/p5-Exception-Handler/distinfo3
-rw-r--r--devel/p5-Exception-Handler/pkg-descr6
-rw-r--r--devel/p5-Exception-Handler/pkg-plist5
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/p5-Exception-Handler/Makefile b/devel/p5-Exception-Handler/Makefile
new file mode 100644
index 000000000000..86b598d14291
--- /dev/null
+++ b/devel/p5-Exception-Handler/Makefile
@@ -0,0 +1,23 @@
+# New ports collection Makefile for: p5-Exception-Handler
+# Date created: 25th April 2007
+# Whom: jeffhung
+#
+# $FreeBSD$
+#
+
+PORTNAME= Exception-Handler
+PORTVERSION= 1.004
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Exception
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= jeffhung@mail2000.com.tw
+COMMENT= Perl5 module that report exceptions with formatted text call-stack.
+
+PERL_CONFIGURE= YES
+
+MAN3= Exception::Handler.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Exception-Handler/distinfo b/devel/p5-Exception-Handler/distinfo
new file mode 100644
index 000000000000..92a15668588f
--- /dev/null
+++ b/devel/p5-Exception-Handler/distinfo
@@ -0,0 +1,3 @@
+MD5 (Exception-Handler-1.004.tar.gz) = 62867ab3a5ccedb3a33b7a949d59e7f5
+SHA256 (Exception-Handler-1.004.tar.gz) = d7dd8a98cbbb59c2a37a3cfac168627afaea3592f96ac345ec1461b5a8dad251
+SIZE (Exception-Handler-1.004.tar.gz) = 3565
diff --git a/devel/p5-Exception-Handler/pkg-descr b/devel/p5-Exception-Handler/pkg-descr
new file mode 100644
index 000000000000..aa6d997035aa
--- /dev/null
+++ b/devel/p5-Exception-Handler/pkg-descr
@@ -0,0 +1,6 @@
+Exception::Handler
+
+Exception::Handler helps to report exceptions with formatted text
+call-stack.
+
+WWW: http://www.cpan.org/
diff --git a/devel/p5-Exception-Handler/pkg-plist b/devel/p5-Exception-Handler/pkg-plist
new file mode 100644
index 000000000000..1fe6784331a2
--- /dev/null
+++ b/devel/p5-Exception-Handler/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Exception/Handler.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Exception/Handler/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Exception/Handler
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Exception
+@dirrmtry %%SITE_PERL%%/Exception