aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-ExtUtils-AutoInstall/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-02 20:01:57 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-02 20:01:57 +0000
commit434f21c6585ed13494121cd7c43b8242441dbd63 (patch)
treeeeea798b82e88af426a081d50283d9f63102f18f /devel/p5-ExtUtils-AutoInstall/Makefile
parent2b4fce87bf725a4c03ccc8440d224cfb63b45a58 (diff)
downloadports-434f21c6585ed13494121cd7c43b8242441dbd63.tar.gz
ports-434f21c6585ed13494121cd7c43b8242441dbd63.zip
Notes
Diffstat (limited to 'devel/p5-ExtUtils-AutoInstall/Makefile')
-rw-r--r--devel/p5-ExtUtils-AutoInstall/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/p5-ExtUtils-AutoInstall/Makefile b/devel/p5-ExtUtils-AutoInstall/Makefile
new file mode 100644
index 000000000000..dda4b8edde02
--- /dev/null
+++ b/devel/p5-ExtUtils-AutoInstall/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: ExtUtils-AutoInstall
+# Date created: 2 December 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ExtUtils-AutoInstall
+PORTVERSION= 0.63
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ExtUtils
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Automatic install of dependencies via CPAN
+
+BUILD_DEPENDS= p5-ExtUtils-MakeMaker>=0:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker \
+ p5-version>=0.28:${PORTSDIR}/devel/p5-version
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= ExtUtils::AutoInstall.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or higer. Install lang/perl5 or lang/perl5.8 and try again.
+.endif
+
+post-extract:
+ @${PERL} -i.bak -ne 'print unless m,^features, .. m,^\);,' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.post.mk>