aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-ExtUtils-Command
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2006-11-02 20:32:16 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2006-11-02 20:32:16 +0000
commit01f9727b8616a5e539e6cea6c8c3435291eebdc3 (patch)
tree77eae4c775a22e380e63a59e0b83dacf0c514bc2 /devel/p5-ExtUtils-Command
parentde89690633f271ada7bfc770002c74708d62f00b (diff)
downloadports-01f9727b8616a5e539e6cea6c8c3435291eebdc3.tar.gz
ports-01f9727b8616a5e539e6cea6c8c3435291eebdc3.zip
Notes
Diffstat (limited to 'devel/p5-ExtUtils-Command')
-rw-r--r--devel/p5-ExtUtils-Command/Makefile28
-rw-r--r--devel/p5-ExtUtils-Command/distinfo3
-rw-r--r--devel/p5-ExtUtils-Command/pkg-descr8
-rw-r--r--devel/p5-ExtUtils-Command/pkg-plist7
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/p5-ExtUtils-Command/Makefile b/devel/p5-ExtUtils-Command/Makefile
new file mode 100644
index 000000000000..964a1682bfbc
--- /dev/null
+++ b/devel/p5-ExtUtils-Command/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: ExtUtils-Command
+# Date created: 02 November 2006
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ExtUtils-Command
+PORTVERSION= 1.12
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ExtUtils
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Utilities to replace common UNIX commands
+
+PERL_CONFIGURE= YES
+
+MAN3= ExtUtils::Command.3 Shell::Command.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-ExtUtils-Command/distinfo b/devel/p5-ExtUtils-Command/distinfo
new file mode 100644
index 000000000000..ac9ca64e6288
--- /dev/null
+++ b/devel/p5-ExtUtils-Command/distinfo
@@ -0,0 +1,3 @@
+MD5 (ExtUtils-Command-1.12.tar.gz) = e446472e9689e5b9d264a03cf45cb8f7
+SHA256 (ExtUtils-Command-1.12.tar.gz) = 735988f42aea745da27800ca197475b2a0ed6d7a098721e704ae402b278e139c
+SIZE (ExtUtils-Command-1.12.tar.gz) = 11073
diff --git a/devel/p5-ExtUtils-Command/pkg-descr b/devel/p5-ExtUtils-Command/pkg-descr
new file mode 100644
index 000000000000..61db110f66cf
--- /dev/null
+++ b/devel/p5-ExtUtils-Command/pkg-descr
@@ -0,0 +1,8 @@
+ExtUtils::Command provides a number of utilities to replace common UNIX
+commands in Makefiles, etc. At present the list includes cp, rm_f,
+rm_rf, mv, cat, eqtime, mkpath, touch, test_f, test_d, chmod, and
+dos2unix. Also included is the companion module Shell::Command, which
+is a thin wrapper for ExtUtils::Command to provide cross-platform
+functions emulating common shell commands.
+
+WWW: http://search.cpan.org/dist/ExtUtils-Command/
diff --git a/devel/p5-ExtUtils-Command/pkg-plist b/devel/p5-ExtUtils-Command/pkg-plist
new file mode 100644
index 000000000000..b0ad587195bd
--- /dev/null
+++ b/devel/p5-ExtUtils-Command/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/ExtUtils/Command.pm
+%%SITE_PERL%%/Shell/Command.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/Command/.packlist
+@dirrmtry %%SITE_PERL%%/ExtUtils
+@dirrmtry %%SITE_PERL%%/Shell
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/Command
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils