aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-ExtUtils-Constant
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2005-02-03 15:43:11 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2005-02-03 15:43:11 +0000
commit2e29b46affdee1d5bd05596181d3237ad3698dc5 (patch)
tree657ae50cc9baab16a9a272f786088a6d093aff78 /devel/p5-ExtUtils-Constant
parent353f0b4e2545efaa3868503843db0093c2bc19c5 (diff)
Notes
Diffstat (limited to 'devel/p5-ExtUtils-Constant')
-rw-r--r--devel/p5-ExtUtils-Constant/Makefile27
-rw-r--r--devel/p5-ExtUtils-Constant/distinfo2
-rw-r--r--devel/p5-ExtUtils-Constant/pkg-descr7
-rw-r--r--devel/p5-ExtUtils-Constant/pkg-plist10
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/p5-ExtUtils-Constant/Makefile b/devel/p5-ExtUtils-Constant/Makefile
new file mode 100644
index 000000000000..3985219990b8
--- /dev/null
+++ b/devel/p5-ExtUtils-Constant/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: ExtUtils-Constant
+# Date created: 03 February 2005
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ExtUtils-Constant
+PORTVERSION= 0.16
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ExtUtils
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Generate XS code to import C header constants
+
+PERL_CONFIGURE= yes
+
+MAN3= ExtUtils::Constant.3 ExtUtils::Constant::Base.3 \
+ ExtUtils::Constant::Utils.3 ExtUtils::Constant::XS.3
+
+post-patch:
+ @${PERL} -pi -e 's!^(\s+INSTALLDIRS\s+=>\s+).*$$!$$1"site",!' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-ExtUtils-Constant/distinfo b/devel/p5-ExtUtils-Constant/distinfo
new file mode 100644
index 000000000000..3bcaa654b56b
--- /dev/null
+++ b/devel/p5-ExtUtils-Constant/distinfo
@@ -0,0 +1,2 @@
+MD5 (ExtUtils-Constant-0.16.tar.gz) = 3d91feaf00aa55f4661197215e9eed94
+SIZE (ExtUtils-Constant-0.16.tar.gz) = 31625
diff --git a/devel/p5-ExtUtils-Constant/pkg-descr b/devel/p5-ExtUtils-Constant/pkg-descr
new file mode 100644
index 000000000000..899437c20b7d
--- /dev/null
+++ b/devel/p5-ExtUtils-Constant/pkg-descr
@@ -0,0 +1,7 @@
+ExtUtils::Constant facilitates generating C and XS wrapper code to allow
+perl modules to AUTOLOAD constants defined in C library header files.
+It is principally used by the h2xs utility, on which this code is based.
+It doesn't contain the routines to scan header files to extract these
+constants.
+
+WWW: http://search.cpan.org/dist/ExtUtils-Constant/
diff --git a/devel/p5-ExtUtils-Constant/pkg-plist b/devel/p5-ExtUtils-Constant/pkg-plist
new file mode 100644
index 000000000000..cc89c37e695c
--- /dev/null
+++ b/devel/p5-ExtUtils-Constant/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/Constant/.packlist
+%%SITE_PERL%%/ExtUtils/Constant.pm
+%%SITE_PERL%%/ExtUtils/Constant/Aaargh56Hash.pm
+%%SITE_PERL%%/ExtUtils/Constant/Base.pm
+%%SITE_PERL%%/ExtUtils/Constant/Utils.pm
+%%SITE_PERL%%/ExtUtils/Constant/XS.pm
+@dirrm %%SITE_PERL%%/ExtUtils/Constant
+@unexec rmdir %D/%%SITE_PERL%%/ExtUtils 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/Constant
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils 2>/dev/null || true