aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-ExtUtils-XSpp
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2009-08-23 23:19:40 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2009-08-23 23:19:40 +0000
commit11d1a24e7259c62bb7398e00125d87650deadb3a (patch)
treea109b839a2daca6661c9e5c41d2f0535d90adb0c /devel/p5-ExtUtils-XSpp
parent718daad0dbb8c1739d8c2b53ff4dbc5ab292e8e7 (diff)
Notes
Diffstat (limited to 'devel/p5-ExtUtils-XSpp')
-rw-r--r--devel/p5-ExtUtils-XSpp/Makefile28
-rw-r--r--devel/p5-ExtUtils-XSpp/distinfo3
-rw-r--r--devel/p5-ExtUtils-XSpp/pkg-descr6
-rw-r--r--devel/p5-ExtUtils-XSpp/pkg-plist10
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/p5-ExtUtils-XSpp/Makefile b/devel/p5-ExtUtils-XSpp/Makefile
new file mode 100644
index 000000000000..4c5f6037abfd
--- /dev/null
+++ b/devel/p5-ExtUtils-XSpp/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-ExtUtils-XSpp
+# Date created: August 22nd 2009
+# Whom: Cezary Morga <cm@therek.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ExtUtils-XSpp
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cm@therek.net
+COMMENT= XS for C++ in Perl
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Base.pm:${PORTSDIR}/devel/p5-Test-Base \
+ ${SITE_PERL}/Test/Differences.pm:${PORTSDIR}/devel/p5-Test-Differences
+
+PERL_MODBUILD= 5.6.1+
+
+MAN1= xspp.1
+MAN3= ExtUtils::XSpp::Typemap.3 \
+ ExtUtils::XSpp::Parser.3 \
+ ExtUtils::XSpp.3 \
+ ExtUtils::XSpp::Node.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-ExtUtils-XSpp/distinfo b/devel/p5-ExtUtils-XSpp/distinfo
new file mode 100644
index 000000000000..4b4ff5861667
--- /dev/null
+++ b/devel/p5-ExtUtils-XSpp/distinfo
@@ -0,0 +1,3 @@
+MD5 (ExtUtils-XSpp-0.04.tar.gz) = cfb4f2a2cf079fe675fdf9ea5ee61e64
+SHA256 (ExtUtils-XSpp-0.04.tar.gz) = e72a2cbb2b7f9817529ff544c6ad3296382ad0bee271f9663923cf98f8e6aba8
+SIZE (ExtUtils-XSpp-0.04.tar.gz) = 71998
diff --git a/devel/p5-ExtUtils-XSpp/pkg-descr b/devel/p5-ExtUtils-XSpp/pkg-descr
new file mode 100644
index 000000000000..f021854d17f3
--- /dev/null
+++ b/devel/p5-ExtUtils-XSpp/pkg-descr
@@ -0,0 +1,6 @@
+XS++ is just a thin layer over plain XS, hence to use it you are
+supposed to know, at the very least, C++ and XS. This means that
+you will need typemaps for both the normal XS pre-processor xsubpp
+and the XS++ pre-processor xspp.
+
+WWW: http://search.cpan.org/dist/ExtUtils-XSpp/
diff --git a/devel/p5-ExtUtils-XSpp/pkg-plist b/devel/p5-ExtUtils-XSpp/pkg-plist
new file mode 100644
index 000000000000..e2e65cb39f3c
--- /dev/null
+++ b/devel/p5-ExtUtils-XSpp/pkg-plist
@@ -0,0 +1,10 @@
+bin/xspp
+%%SITE_PERL%%/ExtUtils/XSpp/Typemap.pm
+%%SITE_PERL%%/ExtUtils/XSpp/Node.pm
+%%SITE_PERL%%/ExtUtils/XSpp/Driver.pm
+%%SITE_PERL%%/ExtUtils/XSpp/Parser.pm
+%%SITE_PERL%%/ExtUtils/XSpp/Grammar.pm
+%%SITE_PERL%%/ExtUtils/XSpp.pod
+%%SITE_PERL%%/ExtUtils/XSpp.pm
+@dirrmtry %%SITE_PERL%%/ExtUtils/XSpp
+@dirrmtry %%SITE_PERL%%/ExtUtils