aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-BOM
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-05-22 15:18:29 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-05-22 15:18:29 +0000
commit8f4ca4ca8ffde959cd6ea44579a48ad6f71a077f (patch)
tree55a2bfd88be36c19ca57f95a6f87926f9bf3ea2b /devel/p5-File-BOM
parentfcb2483463cec312ef2a4b4bc8bfe8e6f744b35b (diff)
downloadports-8f4ca4ca8ffde959cd6ea44579a48ad6f71a077f.tar.gz
ports-8f4ca4ca8ffde959cd6ea44579a48ad6f71a077f.zip
Notes
Diffstat (limited to 'devel/p5-File-BOM')
-rw-r--r--devel/p5-File-BOM/Makefile27
-rw-r--r--devel/p5-File-BOM/distinfo3
-rw-r--r--devel/p5-File-BOM/pkg-descr8
-rw-r--r--devel/p5-File-BOM/pkg-plist5
4 files changed, 43 insertions, 0 deletions
diff --git a/devel/p5-File-BOM/Makefile b/devel/p5-File-BOM/Makefile
new file mode 100644
index 000000000000..c56d13ce5918
--- /dev/null
+++ b/devel/p5-File-BOM/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: devel-p5-File-BOM
+# Date created: 02 April 2010
+# Whom: Eric Freeman <freebsdports@chillibear.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-BOM
+PORTVERSION= 0.14
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= freebsdports@chillibear.com
+COMMENT= Perl module to handle unicode byte order marks
+
+RUN_DEPENDS= p5-Test-Exception>0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Readonly>0:${PORTSDIR}/devel/p5-Readonly \
+ p5-Module-Build>=0.3607:${PORTSDIR}/devel/p5-Module-Build
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= File::BOM.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-BOM/distinfo b/devel/p5-File-BOM/distinfo
new file mode 100644
index 000000000000..6bd78e690b6a
--- /dev/null
+++ b/devel/p5-File-BOM/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-BOM-0.14.tar.gz) = e55642294d8ab369b4dda4e9d57c8e41
+SHA256 (File-BOM-0.14.tar.gz) = 4c9877ceb2e97619a6f7943ca8e0a034900577337e41e65915f2aa29c2ca8cd1
+SIZE (File-BOM-0.14.tar.gz) = 15273
diff --git a/devel/p5-File-BOM/pkg-descr b/devel/p5-File-BOM/pkg-descr
new file mode 100644
index 000000000000..2817d9e8acbc
--- /dev/null
+++ b/devel/p5-File-BOM/pkg-descr
@@ -0,0 +1,8 @@
+This module provides functions for handling unicode byte order
+marks, which are to be found at the beginning of some files and
+streams.
+
+The intention of File::BOM is for files with BOMs to be readable
+as seamlessly as possible, regardless of the encoding used.
+
+WWW: http://search.cpan.org/dist/File-BOM/lib/File/BOM.pm
diff --git a/devel/p5-File-BOM/pkg-plist b/devel/p5-File-BOM/pkg-plist
new file mode 100644
index 000000000000..2e54e6fd27b1
--- /dev/null
+++ b/devel/p5-File-BOM/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/File/BOM.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/BOM/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/BOM
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrmtry %%SITE_PERL%%/File