aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-Find-Closures
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-15 21:39:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-15 21:39:12 +0000
commit971587b290c92da9fed436c4cf8a4788f473a861 (patch)
tree94587a4418856cd0826af28a9ee2f83a8d648b62 /devel/p5-File-Find-Closures
parent3f339aeb0ac1dee633ce21a3f6ac60c9472e847d (diff)
Notes
Diffstat (limited to 'devel/p5-File-Find-Closures')
-rw-r--r--devel/p5-File-Find-Closures/Makefile22
-rw-r--r--devel/p5-File-Find-Closures/distinfo3
-rw-r--r--devel/p5-File-Find-Closures/pkg-descr7
-rw-r--r--devel/p5-File-Find-Closures/pkg-plist8
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/p5-File-Find-Closures/Makefile b/devel/p5-File-Find-Closures/Makefile
new file mode 100644
index 000000000000..eeb6e1c4d76a
--- /dev/null
+++ b/devel/p5-File-Find-Closures/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-File-Find-Closures
+# Date created: 2008-11-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Find-Closures
+PORTVERSION= 1.09
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Functions you can use with File::Find
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Find::Closures.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Find-Closures/distinfo b/devel/p5-File-Find-Closures/distinfo
new file mode 100644
index 000000000000..9eb07366278b
--- /dev/null
+++ b/devel/p5-File-Find-Closures/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-Find-Closures-1.09.tar.gz) = cdbccaf7691412be4e588ca0bc1f82e3
+SHA256 (File-Find-Closures-1.09.tar.gz) = cf25f4d3de7f39941c1966968d900d6523a04a1d0565a4525e10b95db15e4563
+SIZE (File-Find-Closures-1.09.tar.gz) = 7381
diff --git a/devel/p5-File-Find-Closures/pkg-descr b/devel/p5-File-Find-Closures/pkg-descr
new file mode 100644
index 000000000000..bc5cae221065
--- /dev/null
+++ b/devel/p5-File-Find-Closures/pkg-descr
@@ -0,0 +1,7 @@
+I wrote this module as an example of both using closures and using
+File::Find. Students are always asking me what closures are good for,
+and here's some examples. The functions mostly stand alone (i.e. they
+don't need the rest of the module), so rather than creating a
+dependency in your code, just lift the parts you want).
+
+WWW: http://search.cpan.org/dist/File-Find-Closures/
diff --git a/devel/p5-File-Find-Closures/pkg-plist b/devel/p5-File-Find-Closures/pkg-plist
new file mode 100644
index 000000000000..f18ce1088a11
--- /dev/null
+++ b/devel/p5-File-Find-Closures/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Find/Closures/.packlist
+%%SITE_PERL%%/File/Find/Closures.pm
+@dirrmtry %%SITE_PERL%%/File/Find
+@dirrmtry %%SITE_PERL%%/File
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Find/Closures
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Find
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File