aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-Find-Rule/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2004-02-26 15:46:05 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2004-02-26 15:46:05 +0000
commitf6f54a1fea011289cc170b7e8bd1298120f333b7 (patch)
tree020185ea5ae096dded15dcced1c6482a18e42653 /devel/p5-File-Find-Rule/Makefile
parent2195b09cdef0cae41297b8978d285121812db104 (diff)
downloadports-f6f54a1fea011289cc170b7e8bd1298120f333b7.tar.gz
ports-f6f54a1fea011289cc170b7e8bd1298120f333b7.zip
Notes
Diffstat (limited to 'devel/p5-File-Find-Rule/Makefile')
-rw-r--r--devel/p5-File-Find-Rule/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/devel/p5-File-Find-Rule/Makefile b/devel/p5-File-Find-Rule/Makefile
index 1799cc23ae58..b8f4557043e9 100644
--- a/devel/p5-File-Find-Rule/Makefile
+++ b/devel/p5-File-Find-Rule/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= File-Find-Rule
-PORTVERSION= 0.20
+PORTVERSION= 0.27
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= File
@@ -19,8 +19,9 @@ BUILD_DEPENDS= ${SITE_PERL}/Number/Compare.pm:${PORTSDIR}/math/p5-Number-Compare
${SITE_PERL}/Text/Glob.pm:${PORTSDIR}/textproc/p5-Text-Glob
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_MODBUILD= yes
+MAN1= findrule.1
MAN3= File::Find::Rule.3 File::Find::Rule::Extending.3 \
File::Find::Rule::Procedural.3
@@ -31,4 +32,8 @@ BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
.endif
+.if ${PERL_LEVEL} < 500702
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
.include <bsd.port.post.mk>