aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-Grep
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-05-10 15:10:40 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-05-10 15:10:40 +0000
commitd455aa29424b49be9a5c7920b3191d87722ecd56 (patch)
tree9e17746948e7c775b8cdccd2b195c6c5c74bb263 /devel/p5-File-Grep
parenta768751a4a409f829194f40b3479c19a0a9ebd61 (diff)
downloadports-d455aa29424b49be9a5c7920b3191d87722ecd56.tar.gz
ports-d455aa29424b49be9a5c7920b3191d87722ecd56.zip
Notes
Diffstat (limited to 'devel/p5-File-Grep')
-rw-r--r--devel/p5-File-Grep/Makefile28
-rw-r--r--devel/p5-File-Grep/distinfo2
-rw-r--r--devel/p5-File-Grep/pkg-descr4
-rw-r--r--devel/p5-File-Grep/pkg-plist5
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/p5-File-Grep/Makefile b/devel/p5-File-Grep/Makefile
new file mode 100644
index 000000000000..5323bdc1f5dd
--- /dev/null
+++ b/devel/p5-File-Grep/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: File-Grep
+# Date created: 08 May 2004
+# Whom: Xavier Beaudouin <kiwi@oav.net>
+#
+# $FreeBSD$
+
+PORTNAME= File-Grep
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kiwi@oav.net
+COMMENT= Perl Module that Find matches to a pattern in files or function
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Grep.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our (\S+)/use vars qw{$$1};$$1/g' ${WRKSRC}/Grep.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-File-Grep/distinfo b/devel/p5-File-Grep/distinfo
new file mode 100644
index 000000000000..cd559744328b
--- /dev/null
+++ b/devel/p5-File-Grep/distinfo
@@ -0,0 +1,2 @@
+MD5 (File-Grep-0.01.tar.gz) = dbb9c99036208f3897fe81415c8d4ac9
+SIZE (File-Grep-0.01.tar.gz) = 4649
diff --git a/devel/p5-File-Grep/pkg-descr b/devel/p5-File-Grep/pkg-descr
new file mode 100644
index 000000000000..9b624b74951b
--- /dev/null
+++ b/devel/p5-File-Grep/pkg-descr
@@ -0,0 +1,4 @@
+The File::Grep module is designed for find matches to a pattern in
+a series of files and related functions.
+
+WWW: http://search.cpan.org/dist/File-Grep/
diff --git a/devel/p5-File-Grep/pkg-plist b/devel/p5-File-Grep/pkg-plist
new file mode 100644
index 000000000000..4c165cb89e6d
--- /dev/null
+++ b/devel/p5-File-Grep/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/File/Grep.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Grep/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Grep
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/File 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/File 2>/dev/null || true