aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-HomeDir-PathClass
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-12 10:37:01 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-12 10:37:01 +0000
commite5f5ae82d9cd6140a7349792b7e5435b421ff7b0 (patch)
tree301bb74e32a3f5b5c6c3c85036fdcb10f7e7e997 /devel/p5-File-HomeDir-PathClass
parent9663ccc4a71ad652777201cf398302d68ba2324e (diff)
Notes
Diffstat (limited to 'devel/p5-File-HomeDir-PathClass')
-rw-r--r--devel/p5-File-HomeDir-PathClass/Makefile35
-rw-r--r--devel/p5-File-HomeDir-PathClass/distinfo2
-rw-r--r--devel/p5-File-HomeDir-PathClass/pkg-descr8
-rw-r--r--devel/p5-File-HomeDir-PathClass/pkg-plist3
4 files changed, 48 insertions, 0 deletions
diff --git a/devel/p5-File-HomeDir-PathClass/Makefile b/devel/p5-File-HomeDir-PathClass/Makefile
new file mode 100644
index 000000000000..ed4938dce45c
--- /dev/null
+++ b/devel/p5-File-HomeDir-PathClass/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-File-HomeDir-PathClass
+# Date created: 2011-10-10
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-HomeDir-PathClass
+PORTVERSION= 1.112.060
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= File::HomeDir returning Path::Class objects
+
+BUILD_DEPENDS= p5-File-HomeDir>=0.93:${PORTSDIR}/devel/p5-File-HomeDir \
+ p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
+ p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter
+RUN_DEPENDS= p5-File-HomeDir>=0.93:${PORTSDIR}/devel/p5-File-HomeDir \
+ p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
+ p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter
+
+PERL_MODBUILD= 5.10.0+
+
+MAN3= File::HomeDir::PathClass.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-File-HomeDir-PathClass/distinfo b/devel/p5-File-HomeDir-PathClass/distinfo
new file mode 100644
index 000000000000..9c2f19cc9e4e
--- /dev/null
+++ b/devel/p5-File-HomeDir-PathClass/distinfo
@@ -0,0 +1,2 @@
+SHA256 (File-HomeDir-PathClass-1.112060.tar.gz) = cf9b9f7196a7eeb7f3cc641e7b25c4d550337351c3f8ea40a4e49cbf4a80ceea
+SIZE (File-HomeDir-PathClass-1.112060.tar.gz) = 13088
diff --git a/devel/p5-File-HomeDir-PathClass/pkg-descr b/devel/p5-File-HomeDir-PathClass/pkg-descr
new file mode 100644
index 000000000000..95e673531dc1
--- /dev/null
+++ b/devel/p5-File-HomeDir-PathClass/pkg-descr
@@ -0,0 +1,8 @@
+File::HomeDir::PathClass is just a wrapper around File::HomeDir methods,
+transforming their return value to Path::Class objects. This allows for easier
+usage of the value.
+
+Refer to File::HomeDir#METHODS for a list of which functions are supported.
+File::HomeDir::PathClass supports both original File::HomeDir interfaces.
+
+WWW: http://search.cpan.org/dist/File-HomeDir-PathClass/
diff --git a/devel/p5-File-HomeDir-PathClass/pkg-plist b/devel/p5-File-HomeDir-PathClass/pkg-plist
new file mode 100644
index 000000000000..88b6b7a02066
--- /dev/null
+++ b/devel/p5-File-HomeDir-PathClass/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/File/HomeDir/PathClass.pm
+@dirrmtry %%SITE_PERL%%/File/HomeDir
+@dirrmtry %%SITE_PERL%%/File