aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-Modified
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-12-06 10:49:10 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-12-06 10:49:10 +0000
commit36adff5587a317cc4a9f87f6445b16f16db00430 (patch)
treebf2ae9c0c8bdcc150c5d53f5c81f5c4b82c56f92 /devel/p5-File-Modified
parenta95bd6291939b4a49368ae8cfac81342488defb2 (diff)
downloadports-36adff5587a317cc4a9f87f6445b16f16db00430.tar.gz
ports-36adff5587a317cc4a9f87f6445b16f16db00430.zip
Notes
Diffstat (limited to 'devel/p5-File-Modified')
-rw-r--r--devel/p5-File-Modified/Makefile20
-rw-r--r--devel/p5-File-Modified/distinfo4
-rw-r--r--devel/p5-File-Modified/pkg-plist6
3 files changed, 24 insertions, 6 deletions
diff --git a/devel/p5-File-Modified/Makefile b/devel/p5-File-Modified/Makefile
index 2ac33282e8f5..0a64cb2e7106 100644
--- a/devel/p5-File-Modified/Makefile
+++ b/devel/p5-File-Modified/Makefile
@@ -4,7 +4,7 @@
# $FreeBSD$
PORTNAME= File-Modified
-PORTVERSION= 0.06
+PORTVERSION= 0.07
PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
@@ -21,14 +21,28 @@ PERL_CONFIGURE= yes
MAN3= File::Modified.3
+.if !defined(NOPORTDOCS)
+PORTDOCS= Changes README bug.txt
+EXAMPLES= example/1.pl example/Export.cfg example/Import.cfg
+
+post-install:
+ @${MKDIR} ${DOCSDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ @${INSTALL_DATA} ${EXAMPLES:S|^|${WRKSRC}/|} ${EXAMPLESDIR}
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+.endif
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800
BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-.endif
+.if ${PERL_LEVEL} < 500600
post-patch:
- ${PERL} -pi -e 's/\r\n/\n/;' -e 's/^use warnings;//' ${WRKSRC}/Modified.pm
+ @${PERL} -pi -e 's/\r\n/\n/;' -e 's/^use warnings;//' ${WRKSRC}/lib/File/Modified.pm
+.endif
+.endif
.include <bsd.port.post.mk>
diff --git a/devel/p5-File-Modified/distinfo b/devel/p5-File-Modified/distinfo
index b5d276109efa..30b4e740f8e0 100644
--- a/devel/p5-File-Modified/distinfo
+++ b/devel/p5-File-Modified/distinfo
@@ -1,2 +1,2 @@
-MD5 (File-Modified-0.06.tar.gz) = d1fe91da113dfe9e96952f04dcaae5e4
-SIZE (File-Modified-0.06.tar.gz) = 6271
+MD5 (File-Modified-0.07.tar.gz) = 271a991b96ccbdaeb7098272c9f97d51
+SIZE (File-Modified-0.07.tar.gz) = 7164
diff --git a/devel/p5-File-Modified/pkg-plist b/devel/p5-File-Modified/pkg-plist
index c84757d19461..8844a3fb33a9 100644
--- a/devel/p5-File-Modified/pkg-plist
+++ b/devel/p5-File-Modified/pkg-plist
@@ -1,5 +1,9 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Modified/.packlist
%%SITE_PERL%%/File/Modified.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Modified/.packlist
+%%PORTDOCS%%%%EXAMPLESDIR%%/1.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/Export.cfg
+%%PORTDOCS%%%%EXAMPLESDIR%%/Import.cfg
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Modified
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/File 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/File 2>/dev/null || true