aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-NCopy
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2003-05-18 14:17:52 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2003-05-18 14:17:52 +0000
commite6cb8b8dbd250d99c65845464aeebdb3632e162c (patch)
tree905ea5abf6afa5476a419f920e524e104b671594 /devel/p5-File-NCopy
parent6d2c80a2a3573729c478e8a5b486aa56edabf61a (diff)
downloadports-e6cb8b8dbd250d99c65845464aeebdb3632e162c.tar.gz
ports-e6cb8b8dbd250d99c65845464aeebdb3632e162c.zip
Notes
Diffstat (limited to 'devel/p5-File-NCopy')
-rw-r--r--devel/p5-File-NCopy/Makefile29
-rw-r--r--devel/p5-File-NCopy/distinfo1
-rw-r--r--devel/p5-File-NCopy/pkg-descr19
-rw-r--r--devel/p5-File-NCopy/pkg-plist5
4 files changed, 54 insertions, 0 deletions
diff --git a/devel/p5-File-NCopy/Makefile b/devel/p5-File-NCopy/Makefile
new file mode 100644
index 000000000000..5785d6e6cd29
--- /dev/null
+++ b/devel/p5-File-NCopy/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: File-NCopy
+# Date created: 18 May 2003
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-NCopy
+PORTVERSION= 0.34
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/M/MZ/MZSANFORD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Copy file(s) to directories/file
+
+PERL_CONFIGURE= yes
+
+MAN3= File::NCopy.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+BUILD_DEPENDS= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-File-NCopy/distinfo b/devel/p5-File-NCopy/distinfo
new file mode 100644
index 000000000000..58b4ad500a9c
--- /dev/null
+++ b/devel/p5-File-NCopy/distinfo
@@ -0,0 +1 @@
+MD5 (File-NCopy-0.34.tar.gz) = a2633eb0f3f8a6906303e709a35af26f
diff --git a/devel/p5-File-NCopy/pkg-descr b/devel/p5-File-NCopy/pkg-descr
new file mode 100644
index 000000000000..6b603931c767
--- /dev/null
+++ b/devel/p5-File-NCopy/pkg-descr
@@ -0,0 +1,19 @@
+File::NCopy::copy copies files to directories, or a single file to
+another file. You can also use a reference to a file handle if you wish
+whem doing a file to file copy. The functionality is very similar to
+cp. If the argument is a directory to directory copy and the recursive
+flag is set then it is done recursively like cp -R. In fact it behaves
+like cp on Unix for the most part.
+
+If called in array context, an array of successful copies is returned,
+otherwise the number of succesful copies is returned. If passed a file
+handle, it's difficult to make sure the file we are copying isn't the
+same that we are copying to, since by opening the file in write mode it
+gets pooched. To avoid this use file names instead, if at all possible,
+especially for the to file. If passed a file handle, it is not closed
+when copy returns, files opened by copy are closed.
+
+WWW: http://search.cpan.org/dist/File-NCopy/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/devel/p5-File-NCopy/pkg-plist b/devel/p5-File-NCopy/pkg-plist
new file mode 100644
index 000000000000..db310a65bb04
--- /dev/null
+++ b/devel/p5-File-NCopy/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/NCopy/.packlist
+%%SITE_PERL%%/File/NCopy.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/NCopy
+@unexec rmdir %D/%%SITE_PERL%%/File 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/File 2>/dev/null || true