aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-Pid-Quick
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-05-08 08:54:22 +0000
committerWen Heping <wen@FreeBSD.org>2010-05-08 08:54:22 +0000
commit22e1d290ccb3a77b5a0dd31215b07cb876d3114b (patch)
tree298fbef7ddee4567c293ec4ceaf6bcdf2a0e600b /devel/p5-File-Pid-Quick
parent7e00dce776caf46cff000da9de3c594d560158c8 (diff)
downloadports-22e1d290ccb3a77b5a0dd31215b07cb876d3114b.tar.gz
ports-22e1d290ccb3a77b5a0dd31215b07cb876d3114b.zip
Notes
Diffstat (limited to 'devel/p5-File-Pid-Quick')
-rw-r--r--devel/p5-File-Pid-Quick/Makefile25
-rw-r--r--devel/p5-File-Pid-Quick/distinfo3
-rw-r--r--devel/p5-File-Pid-Quick/pkg-descr12
-rw-r--r--devel/p5-File-Pid-Quick/pkg-plist7
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/p5-File-Pid-Quick/Makefile b/devel/p5-File-Pid-Quick/Makefile
new file mode 100644
index 000000000000..0eae3a895ab5
--- /dev/null
+++ b/devel/p5-File-Pid-Quick/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: devel-p5-File-Pid-Quick
+# Date created: 03 April 2010
+# Whom: Eric Freeman <freebsdports@chillibear.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Pid-Quick
+PORTVERSION= 1.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= freebsdports@chillibear.com
+COMMENT= Associates a PID file with your script
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Pid::Quick.3
+
+regression-test:
+ cd ${WRKSRC} && ${MAKE} test
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Pid-Quick/distinfo b/devel/p5-File-Pid-Quick/distinfo
new file mode 100644
index 000000000000..f1c4c6c8d978
--- /dev/null
+++ b/devel/p5-File-Pid-Quick/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-Pid-Quick-1.02.tar.gz) = 8cfb5d1b6d16a1f16571f8dfc5f0a1bc
+SHA256 (File-Pid-Quick-1.02.tar.gz) = e040c06c38513b86d85f08807904ca3c14625332a415d731f597eafa4407d8e0
+SIZE (File-Pid-Quick-1.02.tar.gz) = 4343
diff --git a/devel/p5-File-Pid-Quick/pkg-descr b/devel/p5-File-Pid-Quick/pkg-descr
new file mode 100644
index 000000000000..720ce4bbb1b5
--- /dev/null
+++ b/devel/p5-File-Pid-Quick/pkg-descr
@@ -0,0 +1,12 @@
+This module associates a PID file with your script for the purpose
+of keeping more than one copy from running (concurrency prevention).
+It creates the PID file, checks for its existence when the script
+is run, terminates the script if there is already an instance running,
+and removes the PID file when the script finishes.
+
+This module's objective is to provide a completely simplified
+interface that makes adding PID-file-based concurrency prevention
+to your script as quick and simple as possible; hence File::Pid::Quick.
+For a more nuanced implementation of PID files, please see File::Pid.
+
+WWW: http://search.cpan.org/dist/File-Pid-Quick/Quick.pm
diff --git a/devel/p5-File-Pid-Quick/pkg-plist b/devel/p5-File-Pid-Quick/pkg-plist
new file mode 100644
index 000000000000..fa527c83fdc7
--- /dev/null
+++ b/devel/p5-File-Pid-Quick/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/File/Pid/Quick.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Pid/Quick/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Pid/Quick
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Pid
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrmtry %%SITE_PERL%%/File/Pid
+@dirrmtry %%SITE_PERL%%/File