aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-Slurp-Tree
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-15 02:07:18 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-15 02:07:18 +0000
commitb07cc9815904bab63c08cd1852819e66a93bb536 (patch)
tree1889d483771176ca8a70bfd144f4f3714d53784d /devel/p5-File-Slurp-Tree
parent90651fb2d552dceb3c011ec62e7616139914f451 (diff)
downloadports-b07cc9815904bab63c08cd1852819e66a93bb536.tar.gz
ports-b07cc9815904bab63c08cd1852819e66a93bb536.zip
Notes
Diffstat (limited to 'devel/p5-File-Slurp-Tree')
-rw-r--r--devel/p5-File-Slurp-Tree/Makefile26
-rw-r--r--devel/p5-File-Slurp-Tree/distinfo3
-rw-r--r--devel/p5-File-Slurp-Tree/pkg-descr14
-rw-r--r--devel/p5-File-Slurp-Tree/pkg-plist8
4 files changed, 51 insertions, 0 deletions
diff --git a/devel/p5-File-Slurp-Tree/Makefile b/devel/p5-File-Slurp-Tree/Makefile
new file mode 100644
index 000000000000..8ced9e7f3529
--- /dev/null
+++ b/devel/p5-File-Slurp-Tree/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-File-Slurp-Tree
+# Date created: 2006-07-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Slurp-Tree
+PORTVERSION= 1.24
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Slurp and emit file trees as nested hashes
+
+BUILD_DEPENDS= ${SITE_PERL}/File/Find/Rule.pm:${PORTSDIR}/devel/p5-File-Find-Rule \
+ ${SITE_PERL}/File/Slurp.pm:${PORTSDIR}/devel/p5-File-Slurp
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Slurp::Tree.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Slurp-Tree/distinfo b/devel/p5-File-Slurp-Tree/distinfo
new file mode 100644
index 000000000000..4c68ae796e7d
--- /dev/null
+++ b/devel/p5-File-Slurp-Tree/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-Slurp-Tree-1.24.tar.gz) = 3d4287dd9697fc8fe402399841a6c742
+SHA256 (File-Slurp-Tree-1.24.tar.gz) = 2c96db39084cd2760dc5163d64aff0ade0ee6af5f738692b3357898f2d6b04bf
+SIZE (File-Slurp-Tree-1.24.tar.gz) = 3395
diff --git a/devel/p5-File-Slurp-Tree/pkg-descr b/devel/p5-File-Slurp-Tree/pkg-descr
new file mode 100644
index 000000000000..146586c6f297
--- /dev/null
+++ b/devel/p5-File-Slurp-Tree/pkg-descr
@@ -0,0 +1,14 @@
+File::Slurp::Tree provides functions for slurping and emitting trees
+of files and directories.
+
+ # an example of use in a test suite
+ use Test::More tests => 1;
+ use File::Slurp::Tree;
+ is_deeply( slurp_tree( "t/some_path" ), { foo => {}, bar => "sample\n" },
+ "some_path contains a directory called foo, and a file bar" );
+
+The tree datastructure is a hash of hashes. The keys of each hash are
+names of directories or files. Directories have hash references as
+their value, files have a scalar which holds the contents of the file.
+
+WWW: http://search.cpan.org/dist/File-Slurp-Tree/
diff --git a/devel/p5-File-Slurp-Tree/pkg-plist b/devel/p5-File-Slurp-Tree/pkg-plist
new file mode 100644
index 000000000000..6436be41d6fd
--- /dev/null
+++ b/devel/p5-File-Slurp-Tree/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Slurp/Tree/.packlist
+%%SITE_PERL%%/File/Slurp/Tree.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Slurp/Tree
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Slurp
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrmtry %%SITE_PERL%%/File/Slurp
+@dirrmtry %%SITE_PERL%%/File