aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-Spec
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-04-25 10:47:38 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-04-25 10:47:38 +0000
commit2bc125db0be8f6077dfd3833df6acaa9cee96d53 (patch)
tree5652ec0aa5734dbaf59f22f2ebac7d572d521330 /devel/p5-File-Spec
parent348696956445b62065569ebeffda4d57d4208d73 (diff)
downloadports-2bc125db0be8f6077dfd3833df6acaa9cee96d53.tar.gz
ports-2bc125db0be8f6077dfd3833df6acaa9cee96d53.zip
Notes
Diffstat (limited to 'devel/p5-File-Spec')
-rw-r--r--devel/p5-File-Spec/Makefile32
-rw-r--r--devel/p5-File-Spec/distinfo1
-rw-r--r--devel/p5-File-Spec/pkg-comment1
-rw-r--r--devel/p5-File-Spec/pkg-descr9
-rw-r--r--devel/p5-File-Spec/pkg-plist12
5 files changed, 55 insertions, 0 deletions
diff --git a/devel/p5-File-Spec/Makefile b/devel/p5-File-Spec/Makefile
new file mode 100644
index 000000000000..fd933a3c637b
--- /dev/null
+++ b/devel/p5-File-Spec/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-File-Spec
+# Date created: November 22, 2000
+# Whom: Donald Burr <dburr@FreeBSD.ORG>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Spec
+PORTVERSION= 0.82
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dburr@FreeBSD.ORG
+
+PERL_CONFIGURE= yes
+MODULE_PREFIX= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}
+CONFIGURE_ARGS+=\
+ INSTALLPRIVLIB=${MODULE_PREFIX} \
+ INSTALLARCHLIB=${MODULE_PREFIX}/${PERL_ARCH}
+
+MAN3= File::Spec.3 \
+ File::Spec::Functions.3 \
+ File::Spec::Mac.3 \
+ File::Spec::OS2.3 \
+ File::Spec::Unix.3 \
+ File::Spec::VMS.3 \
+ File::Spec::Win32.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Spec/distinfo b/devel/p5-File-Spec/distinfo
new file mode 100644
index 000000000000..549bcdacad99
--- /dev/null
+++ b/devel/p5-File-Spec/distinfo
@@ -0,0 +1 @@
+MD5 (File-Spec-0.82.tar.gz) = df27080f675cdd6299c4f6b87ea859bd
diff --git a/devel/p5-File-Spec/pkg-comment b/devel/p5-File-Spec/pkg-comment
new file mode 100644
index 000000000000..a945e920b6e8
--- /dev/null
+++ b/devel/p5-File-Spec/pkg-comment
@@ -0,0 +1 @@
+A Perl module for portably manipulating file specifications
diff --git a/devel/p5-File-Spec/pkg-descr b/devel/p5-File-Spec/pkg-descr
new file mode 100644
index 000000000000..c6b391dddffe
--- /dev/null
+++ b/devel/p5-File-Spec/pkg-descr
@@ -0,0 +1,9 @@
+This module is designed to support operations commonly
+performed on file specifications (usually called "file
+names", but not to be confused with the contents of a
+file, or Perl's file handles), such as concatenating
+several directory and file names into a single path, or
+determining whether a path is rooted. It is based on code
+directly taken from MakeMaker 5.17, code written by
+Andreas Koenig, Andy Dougherty, Charles Bailey, Ilya
+Zakharevich, Paul Schinder, and others.
diff --git a/devel/p5-File-Spec/pkg-plist b/devel/p5-File-Spec/pkg-plist
new file mode 100644
index 000000000000..ca1e9c77b4fb
--- /dev/null
+++ b/devel/p5-File-Spec/pkg-plist
@@ -0,0 +1,12 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Spec/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/Functions.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/Mac.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/OS2.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/Unix.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/VMS.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/Win32.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Spec
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/File/Spec
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/File 2>/dev/null || true