aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-chdir
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2003-12-10 10:32:18 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2003-12-10 10:32:18 +0000
commit824c481c06fb61a9818e592e9b7e77726984ca9e (patch)
treefc5d3aa2452bb1376f53c674468980ea17578df2 /devel/p5-File-chdir
parentf834f97cd587b7ab73b2b8f31343b026e80593c8 (diff)
downloadports-824c481c06fb61a9818e592e9b7e77726984ca9e.tar.gz
ports-824c481c06fb61a9818e592e9b7e77726984ca9e.zip
Notes
Diffstat (limited to 'devel/p5-File-chdir')
-rw-r--r--devel/p5-File-chdir/Makefile22
-rw-r--r--devel/p5-File-chdir/distinfo1
-rw-r--r--devel/p5-File-chdir/pkg-descr12
-rw-r--r--devel/p5-File-chdir/pkg-plist5
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/p5-File-chdir/Makefile b/devel/p5-File-chdir/Makefile
new file mode 100644
index 000000000000..e68dbc8c8625
--- /dev/null
+++ b/devel/p5-File-chdir/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: File-chdir
+# Date created: 10 December 2003
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-chdir
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= A more sensible way to change directories
+
+PERL_CONFIGURE= yes
+
+MAN3= File::chdir.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-chdir/distinfo b/devel/p5-File-chdir/distinfo
new file mode 100644
index 000000000000..a10f9f2b24f3
--- /dev/null
+++ b/devel/p5-File-chdir/distinfo
@@ -0,0 +1 @@
+MD5 (File-chdir-0.06.tar.gz) = 41a4661789f6de97fb632e4560d37864
diff --git a/devel/p5-File-chdir/pkg-descr b/devel/p5-File-chdir/pkg-descr
new file mode 100644
index 000000000000..d2dd0bb72290
--- /dev/null
+++ b/devel/p5-File-chdir/pkg-descr
@@ -0,0 +1,12 @@
+Perl's chdir() has the unfortunate problem of being very, very, very
+global. If any part of your program calls chdir() or if any library you
+use calls chdir(), it changes the current working directory for the
+whole program.
+
+File::chdir gives you an alternative, $CWD and @CWD. These two
+variables combine all the power of chdir(), File::Spec and Cwd.
+
+WWW: http://search.cpan.org/dist/File-chdir/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/devel/p5-File-chdir/pkg-plist b/devel/p5-File-chdir/pkg-plist
new file mode 100644
index 000000000000..ca971eb7651e
--- /dev/null
+++ b/devel/p5-File-chdir/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/chdir/.packlist
+%%SITE_PERL%%/File/chdir.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/chdir
+@unexec rmdir %D/%%SITE_PERL%%/File 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/File 2>/dev/null || true