aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Gearman
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-27 07:14:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-27 07:14:43 +0000
commitccc84cd693e0bc94aef3b598c213a72eda58dc11 (patch)
treeaafd246b13bebd3342208f334a48aab62a5e3b6d /devel/p5-Gearman
parente45d0880ba31c1a590703eaad10705123ba47562 (diff)
Gearman is a system to farm out work to other machines, dispatching function
calls to machines that are better suited to do work, to do work in parallel, to load balance lots of function calls, or to call functions between languages. This is the Perl client component. WWW: http://www.danga.com/gearman/ PR: ports/110876 Submitted by: Vivek Khera <vivek at khera.org>
Notes
Notes: svn path=/head/; revision=188450
Diffstat (limited to 'devel/p5-Gearman')
-rw-r--r--devel/p5-Gearman/Makefile39
-rw-r--r--devel/p5-Gearman/distinfo3
-rw-r--r--devel/p5-Gearman/pkg-descr8
3 files changed, 50 insertions, 0 deletions
diff --git a/devel/p5-Gearman/Makefile b/devel/p5-Gearman/Makefile
new file mode 100644
index 000000000000..f6c76e7de27e
--- /dev/null
+++ b/devel/p5-Gearman/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: p5-Gearman
+# Date created: Mon Mar 26 11:45:06 EDT 2007
+# Whom: Vivek Khera <vivek@khera.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Gearman
+PORTVERSION= 1.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/B/BR/BRADFITZ
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vivek@khera.org
+COMMENT= Gearman client libraray for Perl
+
+MODULE_DEPENDS= p5-String-CRC32>=0.0:${PORTSDIR}/devel/p5-String-CRC32
+RUN_DEPENDS+= ${MODULE_DEPENDS}
+BUILD_DEPENDS+= ${MODULE_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Gearman::Client.3 Gearman::Task.3 Gearman::Worker.3
+PLIST_FILES= %%SITE_PERL%%/Gearman/Client.pm \
+ %%SITE_PERL%%/Gearman/JobStatus.pm \
+ %%SITE_PERL%%/Gearman/Objects.pm \
+ %%SITE_PERL%%/Gearman/ResponseParser.pm \
+ %%SITE_PERL%%/Gearman/ResponseParser/Taskset.pm \
+ %%SITE_PERL%%/Gearman/Task.pm \
+ %%SITE_PERL%%/Gearman/Taskset.pm \
+ %%SITE_PERL%%/Gearman/Util.pm \
+ %%SITE_PERL%%/Gearman/Worker.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Gearman/.packlist
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/Gearman \
+ %%SITE_PERL%%/Gearman/ResponseParser \
+ %%SITE_PERL%%/Gearman
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Gearman/distinfo b/devel/p5-Gearman/distinfo
new file mode 100644
index 000000000000..3d0f7c708207
--- /dev/null
+++ b/devel/p5-Gearman/distinfo
@@ -0,0 +1,3 @@
+MD5 (Gearman-1.02.tar.gz) = b46020d0838fccd516e2b65b88adf587
+SHA256 (Gearman-1.02.tar.gz) = e24ffb70deff76f6583c3c79e765bc3658485f981a221221f6a49d6496f134df
+SIZE (Gearman-1.02.tar.gz) = 15877
diff --git a/devel/p5-Gearman/pkg-descr b/devel/p5-Gearman/pkg-descr
new file mode 100644
index 000000000000..18fd3a7e7ac8
--- /dev/null
+++ b/devel/p5-Gearman/pkg-descr
@@ -0,0 +1,8 @@
+Gearman is a system to farm out work to other machines, dispatching function
+calls to machines that are better suited to do work, to do work in parallel,
+to load balance lots of function calls, or to call functions between
+languages.
+
+This is the Perl client component.
+
+WWW: http://www.danga.com/gearman/