aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Git-Wrapper/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-16 02:52:43 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-16 02:52:43 +0000
commit60ed75db7aabdaa4c41080a6b963e5b083f4c1c8 (patch)
treefbe2bbb1cc5b4004421517392261d992a923849e /devel/p5-Git-Wrapper/Makefile
parent1487d80dbd533c1a303993aef66d10f8f656f22d (diff)
Notes
Diffstat (limited to 'devel/p5-Git-Wrapper/Makefile')
-rw-r--r--devel/p5-Git-Wrapper/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/p5-Git-Wrapper/Makefile b/devel/p5-Git-Wrapper/Makefile
new file mode 100644
index 000000000000..e1bb4de69955
--- /dev/null
+++ b/devel/p5-Git-Wrapper/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Git-Wrapper
+# Date created: 2010-11-12
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Git-Wrapper
+PORTVERSION= 0.013
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Wrap git(7) command-line interface
+
+BUILD_DEPENDS= git>=0:${PORTSDIR}/devel/git
+RUN_DEPENDS= git>=0:${PORTSDIR}/devel/git \
+ p5-File-pushd>=0:${PORTSDIR}/devel/p5-File-pushd
+
+PERL_CONFIGURE= yes
+
+MAN3= Git::Wrapper.3
+
+.include <bsd.port.mk>