aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Hash-AutoHash
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2010-09-18 04:33:05 +0000
committerSahil Tandon <sahil@FreeBSD.org>2010-09-18 04:33:05 +0000
commitcfd1dc5e8599e95c397397fdbecc83af54b045dc (patch)
tree7108eb7cd4fdd43314642ffa12f4695a44545871 /devel/p5-Hash-AutoHash
parentd515cfc0996e331bdb4adad9f8382d932863fe9c (diff)
downloadports-cfd1dc5e8599e95c397397fdbecc83af54b045dc.tar.gz
ports-cfd1dc5e8599e95c397397fdbecc83af54b045dc.zip
Notes
Diffstat (limited to 'devel/p5-Hash-AutoHash')
-rw-r--r--devel/p5-Hash-AutoHash/Makefile27
-rw-r--r--devel/p5-Hash-AutoHash/distinfo3
-rw-r--r--devel/p5-Hash-AutoHash/pkg-descr10
-rw-r--r--devel/p5-Hash-AutoHash/pkg-plist2
4 files changed, 42 insertions, 0 deletions
diff --git a/devel/p5-Hash-AutoHash/Makefile b/devel/p5-Hash-AutoHash/Makefile
new file mode 100644
index 000000000000..cb200970355a
--- /dev/null
+++ b/devel/p5-Hash-AutoHash/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Hash-AutoHash
+# Date created: 2010-09-13
+# Whom: Frederic Culot <frederic@culot.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Hash-AutoHash
+PORTVERSION= 1.12
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= frederic@culot.org
+COMMENT= Object-oriented access to real and tied hashes
+
+BUILD_DEPENDS= p5-Tie-Hash-MultiValue>0:${PORTSDIR}/devel/p5-Tie-Hash-MultiValue
+RUN_DEPENDS:= ${BUILD_DEPENDS} \
+ p5-List-MoreUtils>=0.09:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Tie-ToObject>0:${PORTSDIR}/devel/p5-Tie-ToObject
+TEST_DEPENDS= p5-Test-Deep>0:${PORTSDIR}/devel/p5-Test-Deep
+
+PERL_MODBUILD= 5.8.3+
+
+MAN3= Hash::AutoHash.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Hash-AutoHash/distinfo b/devel/p5-Hash-AutoHash/distinfo
new file mode 100644
index 000000000000..fa98c00a0f72
--- /dev/null
+++ b/devel/p5-Hash-AutoHash/distinfo
@@ -0,0 +1,3 @@
+MD5 (Hash-AutoHash-1.12.tar.gz) = a203fd797f4479bf5e52ca8847f7771d
+SHA256 (Hash-AutoHash-1.12.tar.gz) = 7ca24f4cd3ea6e6cb62fadd7709fa0bc56713acbdd68a66aedbc5c39c6067203
+SIZE (Hash-AutoHash-1.12.tar.gz) = 51234
diff --git a/devel/p5-Hash-AutoHash/pkg-descr b/devel/p5-Hash-AutoHash/pkg-descr
new file mode 100644
index 000000000000..a52495a1357f
--- /dev/null
+++ b/devel/p5-Hash-AutoHash/pkg-descr
@@ -0,0 +1,10 @@
+This is yet another module that lets you access or change the elements
+of a hash using methods with the same name as the element's key. It
+follows in the footsteps of Hash::AsObject, Hash::Inflator,
+Data::OpenStruct::Deep, Object::AutoAccessor, and probably others. The
+main difference between this module and its forebears is that it
+supports tied hashes, in addition to regular hashes. This allows a
+modular division of labor: this class is generic and treats all hashes
+the same; any special semantics come from the tied hash.
+
+WWW: http://search.cpan.org/dist/Hash-AutoHash/
diff --git a/devel/p5-Hash-AutoHash/pkg-plist b/devel/p5-Hash-AutoHash/pkg-plist
new file mode 100644
index 000000000000..b700bf7db6ed
--- /dev/null
+++ b/devel/p5-Hash-AutoHash/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Hash/AutoHash.pm
+@dirrmtry %%SITE_PERL%%/Hash