aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Hash-FieldHash
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-08-10 12:24:48 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-08-10 12:24:48 +0000
commitb515624c9f4781e7698f812b6fcfba2d5ae2cc6b (patch)
tree03a494fc2905f1137defd7216a33aafdb6358d59 /devel/p5-Hash-FieldHash
parent24e2dd9b5ba06440e1126de6255f167590ae63d8 (diff)
Notes
Diffstat (limited to 'devel/p5-Hash-FieldHash')
-rw-r--r--devel/p5-Hash-FieldHash/Makefile42
-rw-r--r--devel/p5-Hash-FieldHash/distinfo2
-rw-r--r--devel/p5-Hash-FieldHash/pkg-descr23
-rw-r--r--devel/p5-Hash-FieldHash/pkg-plist7
4 files changed, 74 insertions, 0 deletions
diff --git a/devel/p5-Hash-FieldHash/Makefile b/devel/p5-Hash-FieldHash/Makefile
new file mode 100644
index 000000000000..4750b4cb98a6
--- /dev/null
+++ b/devel/p5-Hash-FieldHash/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: p5-Hash-FieldHash
+# Date created: 2011-08-01
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Hash-FieldHash
+PORTVERSION= 0.10
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= A lightweight field hash implementation
+
+TEST_DEPENDS= p5-Test-LeakTrace>=0.07:${PORTSDIR}/devel/p5-Test-LeakTrace
+
+PERL_CONFIGURE= 5.8.5+
+
+MAN3= Hash::FieldHash.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500808
+TEST_DEPENDS+= p5-Test-Simple>=0.62:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-MRO-Compat>=0.10:${PORTSDIR}/devel/p5-MRO-Compat
+.endif
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-Devel-PPPort>=3.19:${PORTSDIR}/devel/p5-Devel-PPPort
+RUN_DEPENDS+= p5-parent>=0.221:${PORTSDIR}/devel/p5-parent
+.endif
+
+.if ${PERL_LEVEL} < 501200
+BUILD_DEPENDS+= p5-ExtUtils-ParseXS>=2.21:${PORTSDIR}/devel/p5-ExtUtils-ParseXS
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Hash-FieldHash/distinfo b/devel/p5-Hash-FieldHash/distinfo
new file mode 100644
index 000000000000..516fb8493987
--- /dev/null
+++ b/devel/p5-Hash-FieldHash/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Hash-FieldHash-0.10.tar.gz) = 08d5398624a275888924061f26e83b2eba62ae530fffe32f919e74f1b396b2ea
+SIZE (Hash-FieldHash-0.10.tar.gz) = 35918
diff --git a/devel/p5-Hash-FieldHash/pkg-descr b/devel/p5-Hash-FieldHash/pkg-descr
new file mode 100644
index 000000000000..3c2794a26d9f
--- /dev/null
+++ b/devel/p5-Hash-FieldHash/pkg-descr
@@ -0,0 +1,23 @@
+Hash::FieldHash provides the field hash mechanism which supports the inside-out
+technique.
+
+You may know Hash::Util::FieldHash. It's a very useful module, but too complex
+to understand all the functions and only available in 5.10. H::U::F::Compat is
+available for pre-5.10, but it seems too slow to use.
+
+This is an alternative to H::U::F with following features:
+
+Simpler interface
+- Hash::FieldHash provides a few functions: fieldhash() and fieldhashes().
+ That's enough.
+
+Higher performance
+- Hash::FieldHash is faster than Hash::Util::FieldHash, because its internals
+ use simpler structures.
+
+Relic support
+- Although Hash::FieldHash uses a new feature introduced in Perl 5.10, the uvar
+ magic for hashes described in "GUTS" in Hash::Util::Fieldhash, it supports
+ Perl 5.8 using the traditional tie-hash layer.
+
+WWW: http://search.cpan.org/dist/Hash-FieldHash/
diff --git a/devel/p5-Hash-FieldHash/pkg-plist b/devel/p5-Hash-FieldHash/pkg-plist
new file mode 100644
index 000000000000..7ff44f8c4d7c
--- /dev/null
+++ b/devel/p5-Hash-FieldHash/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Hash/FieldHash.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Hash/FieldHash/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Hash/FieldHash/FieldHash.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Hash/FieldHash/FieldHash.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Hash/FieldHash
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Hash
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Hash