aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Heap-Simple-Perl
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2005-12-20 15:28:59 +0000
committerAaron Dalton <aaron@FreeBSD.org>2005-12-20 15:28:59 +0000
commit42cc30b381a22a262247c5bcfd2508fb113e7eff (patch)
treec73154e947dd9dd979904c01659443655b4f3e6b /devel/p5-Heap-Simple-Perl
parent31714c2a3761a26031f0ff56be5da587ef613629 (diff)
downloadports-42cc30b381a22a262247c5bcfd2508fb113e7eff.tar.gz
ports-42cc30b381a22a262247c5bcfd2508fb113e7eff.zip
Notes
Diffstat (limited to 'devel/p5-Heap-Simple-Perl')
-rw-r--r--devel/p5-Heap-Simple-Perl/Makefile8
-rw-r--r--devel/p5-Heap-Simple-Perl/distinfo5
-rw-r--r--devel/p5-Heap-Simple-Perl/files/patch-Makefile11
-rw-r--r--devel/p5-Heap-Simple-Perl/pkg-plist1
4 files changed, 19 insertions, 6 deletions
diff --git a/devel/p5-Heap-Simple-Perl/Makefile b/devel/p5-Heap-Simple-Perl/Makefile
index 8da5563c6f6b..ec702f42d427 100644
--- a/devel/p5-Heap-Simple-Perl/Makefile
+++ b/devel/p5-Heap-Simple-Perl/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= Heap-Simple-Perl
-PORTVERSION= 0.10
+PORTVERSION= 0.11
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Heap
PKGNAMEPREFIX= p5-
-MAINTAINER= aaron@daltons.ca
+MAINTAINER= aaron@FreeBSD.org
COMMENT= A pure perl implementation of the Heap::Simple interface
BUILD_DEPENDS= ${SITE_PERL}/Heap/Simple.pm:${PORTSDIR}/devel/p5-Heap-Simple
@@ -24,8 +24,8 @@ MAN3= Heap::Simple::Perl.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600
-IGNORE= Uses ??{} in regexps, which came with perl5.6, install lang/perl5 or lang/perl5.8
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl5.8
.endif
.include <bsd.port.post.mk>
diff --git a/devel/p5-Heap-Simple-Perl/distinfo b/devel/p5-Heap-Simple-Perl/distinfo
index c70e5e242069..820f3ecc5c1f 100644
--- a/devel/p5-Heap-Simple-Perl/distinfo
+++ b/devel/p5-Heap-Simple-Perl/distinfo
@@ -1,2 +1,3 @@
-MD5 (Heap-Simple-Perl-0.10.tar.gz) = 1a8947433fe6925161c2dcb2aa091bdb
-SIZE (Heap-Simple-Perl-0.10.tar.gz) = 25285
+MD5 (Heap-Simple-Perl-0.11.tar.gz) = 898458aab2a4eb67b4a199d13fc6e1cf
+SHA256 (Heap-Simple-Perl-0.11.tar.gz) = a5d31b3e77430ae4c5219ccb9ab761c1c6e9a65e0bfdaa8bdbfb4444587d4bbb
+SIZE (Heap-Simple-Perl-0.11.tar.gz) = 27985
diff --git a/devel/p5-Heap-Simple-Perl/files/patch-Makefile b/devel/p5-Heap-Simple-Perl/files/patch-Makefile
new file mode 100644
index 000000000000..c3e5c9d92eb4
--- /dev/null
+++ b/devel/p5-Heap-Simple-Perl/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.PL Wed Jul 27 15:21:08 2005
++++ Makefile.PL Fri Nov 25 19:10:07 2005
+@@ -7,7 +7,7 @@
+
+ # Allows to suppress all questions with -n
+ use Getopt::Std;
+-our $opt_n;
++our $opt_n = 1;
+ getopts("n") || die "Usage: $0 [-n]\n";
+
+ my $benchmark = 0;
diff --git a/devel/p5-Heap-Simple-Perl/pkg-plist b/devel/p5-Heap-Simple-Perl/pkg-plist
index 0e07be6dbe23..91349924ce17 100644
--- a/devel/p5-Heap-Simple-Perl/pkg-plist
+++ b/devel/p5-Heap-Simple-Perl/pkg-plist
@@ -27,6 +27,7 @@
%%SITE_PERL%%/auto/Heap/Simple/Perl/insert.al
%%SITE_PERL%%/auto/Heap/Simple/Perl/key.al
%%SITE_PERL%%/auto/Heap/Simple/Perl/keys.al
+%%SITE_PERL%%/auto/Heap/Simple/Perl/merge_arrays.al
%%SITE_PERL%%/auto/Heap/Simple/Perl/min_key.al
%%SITE_PERL%%/auto/Heap/Simple/Perl/top.al
%%SITE_PERL%%/auto/Heap/Simple/Perl/top_key.al