aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Heap-Simple-XS
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-11-24 10:15:48 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-11-24 10:15:48 +0000
commit33ee3633512461be522d75a952a23aa85e274224 (patch)
treeeb251651b75b4a757d08c73d777772f736e078bf /devel/p5-Heap-Simple-XS
parent00a07f26a5e4b4cee4d618cbb0c11d79cf7b5718 (diff)
downloadports-33ee3633512461be522d75a952a23aa85e274224.tar.gz
ports-33ee3633512461be522d75a952a23aa85e274224.zip
Notes
Diffstat (limited to 'devel/p5-Heap-Simple-XS')
-rw-r--r--devel/p5-Heap-Simple-XS/Makefile31
-rw-r--r--devel/p5-Heap-Simple-XS/distinfo2
-rw-r--r--devel/p5-Heap-Simple-XS/pkg-descr8
-rw-r--r--devel/p5-Heap-Simple-XS/pkg-plist9
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/p5-Heap-Simple-XS/Makefile b/devel/p5-Heap-Simple-XS/Makefile
new file mode 100644
index 000000000000..57af4bf418bb
--- /dev/null
+++ b/devel/p5-Heap-Simple-XS/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Heap-Simple-XS
+# Date created: 11 November 2004
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Heap-Simple-XS
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Heap
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= An XS implementation of the Heap::Simple interface
+
+BUILD_DEPENDS= ${SITE_PERL}/Heap/Simple.pm:${PORTSDIR}/devel/p5-Heap-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Heap::Simple::XS.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Uses ??{} in regexps, which came with perl5.6, install lang/perl5 or lang/perl5.8
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Heap-Simple-XS/distinfo b/devel/p5-Heap-Simple-XS/distinfo
new file mode 100644
index 000000000000..e8a467c89518
--- /dev/null
+++ b/devel/p5-Heap-Simple-XS/distinfo
@@ -0,0 +1,2 @@
+MD5 (Heap-Simple-XS-0.06.tar.gz) = 587d13b368a57bd4f6fc1b4cc117e587
+SIZE (Heap-Simple-XS-0.06.tar.gz) = 55267
diff --git a/devel/p5-Heap-Simple-XS/pkg-descr b/devel/p5-Heap-Simple-XS/pkg-descr
new file mode 100644
index 000000000000..c8ca6c54e664
--- /dev/null
+++ b/devel/p5-Heap-Simple-XS/pkg-descr
@@ -0,0 +1,8 @@
+This module provides an XS implementation of the interface described in
+Heap::Simple. Look there for a description.
+
+WWW: http://search.cpan.org/dist/Heap-Simple-XS/
+Author: Ton Hospel <cpan@ton.iguana.be>
+
+- Aaron Dalton
+aaron@daltons.ca
diff --git a/devel/p5-Heap-Simple-XS/pkg-plist b/devel/p5-Heap-Simple-XS/pkg-plist
new file mode 100644
index 000000000000..f21a63488854
--- /dev/null
+++ b/devel/p5-Heap-Simple-XS/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Heap/Simple/XS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap/Simple/XS/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap/Simple/XS/XS.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap/Simple/XS/XS.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap/Simple/XS
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap/Simple 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Heap 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Heap/Simple 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Heap 2>/dev/null || true