aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-IO-All
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-07-16 02:23:29 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-07-16 02:23:29 +0000
commitabe6243d4e34cc1aca96a4cfa98b4f8e0eb6001a (patch)
treeac7bbf799eeb697fc45fa8c7adc41b3afa1b6f29 /devel/p5-IO-All
parent03942b2d346bc92844358fec6d37683c5e889c32 (diff)
downloadports-abe6243d4e34cc1aca96a4cfa98b4f8e0eb6001a.tar.gz
ports-abe6243d4e34cc1aca96a4cfa98b4f8e0eb6001a.zip
Notes
Diffstat (limited to 'devel/p5-IO-All')
-rw-r--r--devel/p5-IO-All/Makefile39
-rw-r--r--devel/p5-IO-All/distinfo2
-rw-r--r--devel/p5-IO-All/pkg-descr8
-rw-r--r--devel/p5-IO-All/pkg-plist5
4 files changed, 54 insertions, 0 deletions
diff --git a/devel/p5-IO-All/Makefile b/devel/p5-IO-All/Makefile
new file mode 100644
index 000000000000..73c03d512492
--- /dev/null
+++ b/devel/p5-IO-All/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: IO::All
+# Date created: 15 July 2004
+# Whom: Elvis Chiang <elvis@sslab.cs.ccu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-All
+PORTVERSION= 0.22
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/I/IN/INGY/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= IO::All combines all of the best Perl IO modules
+
+BUILD_DEPENDS= ${SITE_PERL}/Spiffy.pm:${PORTSDIR}/devel/p5-Spiffy
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= IO::All.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Filter/Util/Call.pm:${PORTSDIR}/devel/p5-Filter
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+.if ${PERL_LEVEL} < 500703
+BUILD_DEPENDS+= ${SITE_PERL}/Tie/File.pm:${PORTSDIR}/devel/p5-Tie-File
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.8.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-IO-All/distinfo b/devel/p5-IO-All/distinfo
new file mode 100644
index 000000000000..5c3ade4fb354
--- /dev/null
+++ b/devel/p5-IO-All/distinfo
@@ -0,0 +1,2 @@
+MD5 (IO-All-0.22.tar.gz) = fec62c77dd6fe6eea3e06d5b5ed26a1c
+SIZE (IO-All-0.22.tar.gz) = 47711
diff --git a/devel/p5-IO-All/pkg-descr b/devel/p5-IO-All/pkg-descr
new file mode 100644
index 000000000000..fc83401490bc
--- /dev/null
+++ b/devel/p5-IO-All/pkg-descr
@@ -0,0 +1,8 @@
+IO::All - IO::All combines all of the best Perl IO modules
+
+IO::All combines all of the best Perl IO modules into a single Spiffy object
+oriented interface to greatly simplify your everyday Perl IO idioms.
+It exports a single function called io, which returns a new IO::All object.
+And that object can do it all!
+
+WWW: http://search.cpan.org/~ingy/IO-All-0.22/
diff --git a/devel/p5-IO-All/pkg-plist b/devel/p5-IO-All/pkg-plist
new file mode 100644
index 000000000000..a6f2810da16a
--- /dev/null
+++ b/devel/p5-IO-All/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/All/.packlist
+%%SITE_PERL%%/IO/All.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/All
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/ 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/IO 2>/dev/null || true