aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-IO-Async
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-06-14 01:57:12 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-06-14 01:57:12 +0000
commitbe437ad5fa06effc8be322a8b375198fd6e353e8 (patch)
tree6bd0d5f79bd22ec9d5040af1272259883397aeb5 /devel/p5-IO-Async
parent5b5dc26aaea3d8e992e2ff8e3b8697a57f6b8496 (diff)
downloadports-be437ad5fa06effc8be322a8b375198fd6e353e8.tar.gz
ports-be437ad5fa06effc8be322a8b375198fd6e353e8.zip
Notes
Diffstat (limited to 'devel/p5-IO-Async')
-rw-r--r--devel/p5-IO-Async/Makefile25
-rw-r--r--devel/p5-IO-Async/distinfo3
-rw-r--r--devel/p5-IO-Async/pkg-descr10
-rw-r--r--devel/p5-IO-Async/pkg-plist16
4 files changed, 54 insertions, 0 deletions
diff --git a/devel/p5-IO-Async/Makefile b/devel/p5-IO-Async/Makefile
new file mode 100644
index 000000000000..51ea2c33e07f
--- /dev/null
+++ b/devel/p5-IO-Async/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-IO-Async
+# Date created: 2007-06-10
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-Async
+PORTVERSION= 0.07
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= IO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl modules that implement asynchronous filehandle IO
+
+PERL_CONFIGURE= yes
+
+MAN3= IO::Async.3 IO::Async::Buffer.3 IO::Async::ChildManager.3 \
+ IO::Async::Notifier.3 IO::Async::Set.3 \
+ IO::Async::Set::GMainLoop.3 IO::Async::Set::IO_Poll.3 \
+ IO::Async::Set::Select.3 IO::Async::SignalProxy.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-IO-Async/distinfo b/devel/p5-IO-Async/distinfo
new file mode 100644
index 000000000000..76e50d8dc66f
--- /dev/null
+++ b/devel/p5-IO-Async/distinfo
@@ -0,0 +1,3 @@
+MD5 (IO-Async-0.07.tar.gz) = d0addd5a98b59de0c15f6542937ec7f9
+SHA256 (IO-Async-0.07.tar.gz) = 133efb840a7d8d558de7c875aadc176b6dea4d786a6aa53b7eedfb2b223968d2
+SIZE (IO-Async-0.07.tar.gz) = 30647
diff --git a/devel/p5-IO-Async/pkg-descr b/devel/p5-IO-Async/pkg-descr
new file mode 100644
index 000000000000..a45e81dc546b
--- /dev/null
+++ b/devel/p5-IO-Async/pkg-descr
@@ -0,0 +1,10 @@
+This collection of modules allows programs to be written that perform
+asynchronous filehandle IO operations. A typical program using them
+would consist of a single subclass of IO::Async::Set to act as a
+container for a number of IO::Async::Notifier objects (or subclasses
+thereof). The set itself is responsible for checking read- or
+write-readiness, and informing the notifiers of these conditions. The
+notifiers then perform whatever work is required on these conditions,
+by using subclass methods or callback functions.
+
+WWW: http://search.cpan.org/dist/IO-Async/
diff --git a/devel/p5-IO-Async/pkg-plist b/devel/p5-IO-Async/pkg-plist
new file mode 100644
index 000000000000..6e26a805c80b
--- /dev/null
+++ b/devel/p5-IO-Async/pkg-plist
@@ -0,0 +1,16 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/Async/.packlist
+%%SITE_PERL%%/IO/Async.pod
+%%SITE_PERL%%/IO/Async/Buffer.pm
+%%SITE_PERL%%/IO/Async/ChildManager.pm
+%%SITE_PERL%%/IO/Async/Notifier.pm
+%%SITE_PERL%%/IO/Async/Set.pm
+%%SITE_PERL%%/IO/Async/Set/GMainLoop.pm
+%%SITE_PERL%%/IO/Async/Set/IO_Poll.pm
+%%SITE_PERL%%/IO/Async/Set/Select.pm
+%%SITE_PERL%%/IO/Async/SignalProxy.pm
+@dirrmtry %%SITE_PERL%%/mach/auto/IO/Async
+@dirrmtry %%SITE_PERL%%/mach/auto/IO
+@dirrmtry %%SITE_PERL%%/IO/Async/Set
+@dirrmtry %%SITE_PERL%%/IO/Async
+@dirrmtry %%SITE_PERL%%/IO