aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-IO-MultiPipe
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-01-26 22:48:20 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-01-26 22:48:20 +0000
commit3d3cc97306fc6d223393fc8999288fbaf59fb1c5 (patch)
treeb93bd31dc8de3ae8937d74f3acf1df0d1e63f648 /devel/p5-IO-MultiPipe
parentee079202bf10761fb20c9ec6ae2f6562b8faeaa1 (diff)
downloadports-3d3cc97306fc6d223393fc8999288fbaf59fb1c5.tar.gz
ports-3d3cc97306fc6d223393fc8999288fbaf59fb1c5.zip
Notes
Diffstat (limited to 'devel/p5-IO-MultiPipe')
-rw-r--r--devel/p5-IO-MultiPipe/Makefile22
-rw-r--r--devel/p5-IO-MultiPipe/distinfo3
-rw-r--r--devel/p5-IO-MultiPipe/pkg-descr20
-rw-r--r--devel/p5-IO-MultiPipe/pkg-plist5
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/p5-IO-MultiPipe/Makefile b/devel/p5-IO-MultiPipe/Makefile
new file mode 100644
index 000000000000..f81b11725f23
--- /dev/null
+++ b/devel/p5-IO-MultiPipe/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-IO-MultiPipe
+# Date created: 2009-01-14
+# Whom: Zane C, Bowers <vvelox@vvelox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-MultiPipe
+PORTVERSION= 0.0.0
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/V/VV/VVELOX
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= Check for errors when running a command through multiple pipes
+
+PERL_CONFIGURE= yes
+
+MAN3= IO::MultiPipe.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-IO-MultiPipe/distinfo b/devel/p5-IO-MultiPipe/distinfo
new file mode 100644
index 000000000000..62aebf76979d
--- /dev/null
+++ b/devel/p5-IO-MultiPipe/distinfo
@@ -0,0 +1,3 @@
+MD5 (IO-MultiPipe-0.0.0.tar.gz) = 7f311e9405adcb12ddee1edb5f869ade
+SHA256 (IO-MultiPipe-0.0.0.tar.gz) = e300e5ca4c8a80d563b6b75191bdb37bd0833d2d14b7ed6c970cee6a8c0dd17c
+SIZE (IO-MultiPipe-0.0.0.tar.gz) = 3877
diff --git a/devel/p5-IO-MultiPipe/pkg-descr b/devel/p5-IO-MultiPipe/pkg-descr
new file mode 100644
index 000000000000..2cfdb1009482
--- /dev/null
+++ b/devel/p5-IO-MultiPipe/pkg-descr
@@ -0,0 +1,20 @@
+Normally if a part of a pipe fails, depending on the location, it won't
+be detected. This breaks down a command involving pipes and runs each
+command seperately.
+
+It uses open3 to run each chunk of the pipe.
+
+ use IO::MultiPipe;
+
+ my $pipes = IO::MultiPipe->new();
+
+ #This sets the pipe that will be run.
+ $pipes->set('sed s/-// | sed s/123/abc/ | sed s/ABC/abc/');
+ if ($pipes->{error}){
+ print "Error!\n";
+ }
+
+ #'123-ABCxyz' through the command set above.
+ my $returned=$pipes->run('123-ABCxyz');
+
+WWW: http://search.cpan.org/~vvelox/IO-MultiPipe/
diff --git a/devel/p5-IO-MultiPipe/pkg-plist b/devel/p5-IO-MultiPipe/pkg-plist
new file mode 100644
index 000000000000..26b0d3bebd76
--- /dev/null
+++ b/devel/p5-IO-MultiPipe/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/IO/MultiPipe.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/MultiPipe/.packlist
+@dirrmtry %%SITE_PERL%%/IO
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/MultiPipe
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO