aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-IO-Tee
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-01-19 23:32:04 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-01-19 23:32:04 +0000
commit4808806462b3dfac9446d10caa7e03a0064c3c02 (patch)
tree7e3f3db974ae1806f57c16e79f1fac27567c75e9 /devel/p5-IO-Tee
parentcf6325b87dc3becfb9faaa45c3ca3285b8bc0818 (diff)
downloadports-4808806462b3dfac9446d10caa7e03a0064c3c02.tar.gz
ports-4808806462b3dfac9446d10caa7e03a0064c3c02.zip
Notes
Diffstat (limited to 'devel/p5-IO-Tee')
-rw-r--r--devel/p5-IO-Tee/Makefile22
-rw-r--r--devel/p5-IO-Tee/distinfo1
-rw-r--r--devel/p5-IO-Tee/pkg-descr11
-rw-r--r--devel/p5-IO-Tee/pkg-plist2
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/p5-IO-Tee/Makefile b/devel/p5-IO-Tee/Makefile
new file mode 100644
index 000000000000..b1e4989bb2fb
--- /dev/null
+++ b/devel/p5-IO-Tee/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-IO-Tee
+# Date created: Sun Jan 18 07:27:41 CST 2004
+# Whom: dcf@aracnet.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-Tee
+PORTVERSION= 0.64
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dcf@aracnet.com
+COMMENT= Multiplex output to multiple output handles
+
+PERL_CONFIGURE= yes
+
+MAN3= IO::Tee.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-IO-Tee/distinfo b/devel/p5-IO-Tee/distinfo
new file mode 100644
index 000000000000..57fe2dfc7765
--- /dev/null
+++ b/devel/p5-IO-Tee/distinfo
@@ -0,0 +1 @@
+MD5 (IO-Tee-0.64.tar.gz) = 97d91e38fcadc1f01d8030a8d4f30701
diff --git a/devel/p5-IO-Tee/pkg-descr b/devel/p5-IO-Tee/pkg-descr
new file mode 100644
index 000000000000..b2e195603f08
--- /dev/null
+++ b/devel/p5-IO-Tee/pkg-descr
@@ -0,0 +1,11 @@
+IO::Tee
+=======
+
+The `IO::Tee' constructor, given a list of output handles,
+returns a tied handle that can be written to but not read from.
+When written to (using print or printf), it multiplexes the
+output to the list of handles originally passed to the
+constructor. As a shortcut, you can also directly pass a string
+or an array reference to the constructor, in which case
+`IO::File::new' is called for you with the specified argument or
+arguments.
diff --git a/devel/p5-IO-Tee/pkg-plist b/devel/p5-IO-Tee/pkg-plist
new file mode 100644
index 000000000000..100e74e0bb42
--- /dev/null
+++ b/devel/p5-IO-Tee/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/IO/Tee.pm
+@unexec rmdir %D/%%SITE_PERL%%/IO 2>/dev/null || true