aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-IO-YAML/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-22 05:57:22 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-22 05:57:22 +0000
commit61b3509ced58f64082e64db4aaa9f04a33f144f0 (patch)
tree0d1f12ad77a4595e1528da43a26267ec13f5ae57 /devel/p5-IO-YAML/Makefile
parent73e4bb4e43b5584f68e9344c83e18cfe4a6d1f14 (diff)
Notes
Diffstat (limited to 'devel/p5-IO-YAML/Makefile')
-rw-r--r--devel/p5-IO-YAML/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/p5-IO-YAML/Makefile b/devel/p5-IO-YAML/Makefile
new file mode 100644
index 000000000000..f6ee9e6dd984
--- /dev/null
+++ b/devel/p5-IO-YAML/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-IO-YAML
+# Date created: 2006-08-17
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-YAML
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Read and write YAML streams incrementally
+
+RUN_DEPENDS= ${SITE_PERL}/IO/Scalar.pm:${PORTSDIR}/devel/p5-IO-stringy \
+ ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+
+PERL_CONFIGURE= yes
+
+MAN3= IO::YAML.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601 # Inherited from textproc/p5-YAML
+IGNORE= requires perl 5.6.1 or later. Install lang/perl5.8 and try again
+.endif
+
+.if ${PERL_LEVEL} < 500801
+RUN_DEPENDS+= ${SITE_PERL}/Errno.pm:${PORTSDIR}/devel/p5-Errno
+.endif
+
+.include <bsd.port.post.mk>