aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-IPC-Cmd/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-02-16 13:15:06 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-02-16 13:15:06 +0000
commit36a01ef794745e2b071af022daf877609073e916 (patch)
treec1f3773261e314f6092fabd9685908c54234852f /devel/p5-IPC-Cmd/Makefile
parent7a4545d42cd858642bfb80fd3d15ee00844ccfd2 (diff)
downloadports-36a01ef794745e2b071af022daf877609073e916.tar.gz
ports-36a01ef794745e2b071af022daf877609073e916.zip
Notes
Diffstat (limited to 'devel/p5-IPC-Cmd/Makefile')
-rw-r--r--devel/p5-IPC-Cmd/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/p5-IPC-Cmd/Makefile b/devel/p5-IPC-Cmd/Makefile
new file mode 100644
index 000000000000..3bd562215c9f
--- /dev/null
+++ b/devel/p5-IPC-Cmd/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: devel/p5-IPC-Cmd
+# Date created: 16 February 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IPC-Cmd
+PORTVERSION= 0.24
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IPC
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= IPC::Cmd - finding and running system commands made easy
+
+BUILD_DEPENDS= ${SITE_PERL}/Locale/Maketext/Simple.pm:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
+ ${SITE_PERL}/Module/Load/Conditional.pm:${PORTSDIR}/devel/p5-Module-Load-Conditional \
+ ${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run \
+ ${SITE_PERL}/Params/Check.pm:${PORTSDIR}/devel/p5-Params-Check
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= IPC::Cmd.3
+
+.include <bsd.port.mk>