aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-IPC-PubSub
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2007-01-26 15:06:18 +0000
committerAnton Berezin <tobez@FreeBSD.org>2007-01-26 15:06:18 +0000
commit1e0b52895e89cf097b2a62b75762b1f98f3df27c (patch)
treeb772c19ce51aa0bbee934555454394ec6f45f801 /devel/p5-IPC-PubSub
parentd68b123ed02db6e449425d608c5a3f4d4673f6f2 (diff)
downloadports-1e0b52895e89cf097b2a62b75762b1f98f3df27c.tar.gz
ports-1e0b52895e89cf097b2a62b75762b1f98f3df27c.zip
Notes
Diffstat (limited to 'devel/p5-IPC-PubSub')
-rw-r--r--devel/p5-IPC-PubSub/Makefile34
-rw-r--r--devel/p5-IPC-PubSub/distinfo3
-rw-r--r--devel/p5-IPC-PubSub/pkg-descr11
-rw-r--r--devel/p5-IPC-PubSub/pkg-plist20
4 files changed, 68 insertions, 0 deletions
diff --git a/devel/p5-IPC-PubSub/Makefile b/devel/p5-IPC-PubSub/Makefile
new file mode 100644
index 000000000000..f6d94ad0c893
--- /dev/null
+++ b/devel/p5-IPC-PubSub/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: devel/p5-IPC-PubSub
+# Date created: 26 January 2007
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IPC-PubSub
+PORTVERSION= 0.22
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IPC
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Interprocess Publish/Subscribe channels
+
+BUILD_DEPENDS= ${SITE_PERL}/DBM/Deep.pm:${PORTSDIR}/databases/p5-DBM-Deep \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
+ ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/${PERL_ARCH}/Data/UUID.pm:${PORTSDIR}/devel/p5-Data-UUID
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= IPC::PubSub.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-IPC-PubSub/distinfo b/devel/p5-IPC-PubSub/distinfo
new file mode 100644
index 000000000000..d0f7fe91958f
--- /dev/null
+++ b/devel/p5-IPC-PubSub/distinfo
@@ -0,0 +1,3 @@
+MD5 (IPC-PubSub-0.22.tar.gz) = 5f23d20a4d80c21e32fd3631bfd95df9
+SHA256 (IPC-PubSub-0.22.tar.gz) = b432376a0aad5a618e34bb4d04e60348a7011b32621385b794e4e982cb617ce2
+SIZE (IPC-PubSub-0.22.tar.gz) = 19568
diff --git a/devel/p5-IPC-PubSub/pkg-descr b/devel/p5-IPC-PubSub/pkg-descr
new file mode 100644
index 000000000000..3a8f39fef03a
--- /dev/null
+++ b/devel/p5-IPC-PubSub/pkg-descr
@@ -0,0 +1,11 @@
+This module provides a simple API for publishing messages to channels
+and for subscribing to them.
+
+When a message is published on a channel, all subscribers currently in
+that channel will get it on their next "get" or "get_all" call.
+
+Currently, it offers three backends: "DBM_Deep" for on-disk storage,
+"Memcached" for possibly multi-host storage, and "PlainHash" for
+single-process storage.
+
+WWW: http://search.cpan.org/dist/IPC-PubSub/
diff --git a/devel/p5-IPC-PubSub/pkg-plist b/devel/p5-IPC-PubSub/pkg-plist
new file mode 100644
index 000000000000..b03c9879af4e
--- /dev/null
+++ b/devel/p5-IPC-PubSub/pkg-plist
@@ -0,0 +1,20 @@
+%%SITE_PERL%%/IPC/PubSub.pm
+%%SITE_PERL%%/IPC/PubSub/Cache.pm
+%%SITE_PERL%%/IPC/PubSub/Cache/DBM_Deep.pm
+%%SITE_PERL%%/IPC/PubSub/Cache/JiftyDBI.pm
+%%SITE_PERL%%/IPC/PubSub/Cache/JiftyDBI/Stash.pm
+%%SITE_PERL%%/IPC/PubSub/Cache/JiftyDBI/Stash/Item.pm
+%%SITE_PERL%%/IPC/PubSub/Cache/JiftyDBI/Stash/Publisher.pm
+%%SITE_PERL%%/IPC/PubSub/Cache/Memcached.pm
+%%SITE_PERL%%/IPC/PubSub/Cache/PlainHash.pm
+%%SITE_PERL%%/IPC/PubSub/Cacheable.pm
+%%SITE_PERL%%/IPC/PubSub/Publisher.pm
+%%SITE_PERL%%/IPC/PubSub/Subscriber.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC/PubSub/.packlist
+@dirrmtry %%SITE_PERL%%/IPC/PubSub/Cache/JiftyDBI/Stash
+@dirrmtry %%SITE_PERL%%/IPC/PubSub/Cache/JiftyDBI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC/PubSub
+@dirrmtry %%SITE_PERL%%/IPC/PubSub/Cache
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC
+@dirrmtry %%SITE_PERL%%/IPC/PubSub
+@dirrmtry %%SITE_PERL%%/IPC