aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Inline-ASM
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-12-15 17:20:26 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-12-15 17:20:26 +0000
commit8577906bf743a6dbe32e49efcfa322131eb6601d (patch)
tree115f8f53f5e587fe0a6cc1cdbcfe58325ab16186 /devel/p5-Inline-ASM
parent16f8359d405126b0b63afa7cd469b37d2d47ef05 (diff)
downloadports-8577906bf743a6dbe32e49efcfa322131eb6601d.tar.gz
ports-8577906bf743a6dbe32e49efcfa322131eb6601d.zip
Notes
Diffstat (limited to 'devel/p5-Inline-ASM')
-rw-r--r--devel/p5-Inline-ASM/Makefile26
-rw-r--r--devel/p5-Inline-ASM/distinfo1
-rw-r--r--devel/p5-Inline-ASM/pkg-comment1
-rw-r--r--devel/p5-Inline-ASM/pkg-descr10
-rw-r--r--devel/p5-Inline-ASM/pkg-plist6
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/p5-Inline-ASM/Makefile b/devel/p5-Inline-ASM/Makefile
new file mode 100644
index 000000000000..08390883945c
--- /dev/null
+++ b/devel/p5-Inline-ASM/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Inline::ASM
+# Date created: 14 Dec 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Inline-ASM
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Inline
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Inline.pm:${PORTSDIR}/devel/p5-Inline
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= </dev/null
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Inline::ASM.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Inline-ASM/distinfo b/devel/p5-Inline-ASM/distinfo
new file mode 100644
index 000000000000..7361522c6b68
--- /dev/null
+++ b/devel/p5-Inline-ASM/distinfo
@@ -0,0 +1 @@
+MD5 (Inline-ASM-0.03.tar.gz) = af0241d8d9993598fc146eab4be247b2
diff --git a/devel/p5-Inline-ASM/pkg-comment b/devel/p5-Inline-ASM/pkg-comment
new file mode 100644
index 000000000000..2a4a6bab45ba
--- /dev/null
+++ b/devel/p5-Inline-ASM/pkg-comment
@@ -0,0 +1 @@
+Write Perl Subroutines in assembler
diff --git a/devel/p5-Inline-ASM/pkg-descr b/devel/p5-Inline-ASM/pkg-descr
new file mode 100644
index 000000000000..259fcf1d0f22
--- /dev/null
+++ b/devel/p5-Inline-ASM/pkg-descr
@@ -0,0 +1,10 @@
+Inline::ASM allows you to write Perl subroutines in assembly language.
+Of course, many C compilers allow you to put assembly right in your C
+code, so this module does not provide any new functionality. It does,
+however, provide a feature most C compilers don't: you can mix different
+assembler syntaxes in the same file!
+
+WWW: http://search.cpan.org/search?dist=Inline-ASM
+
+-- Sergey Skvortsov
+skv@protey.ru
diff --git a/devel/p5-Inline-ASM/pkg-plist b/devel/p5-Inline-ASM/pkg-plist
new file mode 100644
index 000000000000..68296a5679c9
--- /dev/null
+++ b/devel/p5-Inline-ASM/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Inline/ASM/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Inline/ASM.pm
+lib/perl5/site_perl/%%PERL_VER%%/Inline/ASM.pod
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Inline/ASM
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Inline 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Inline 2>/dev/null || true