aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Inline-CPP
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-12-15 17:31:27 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-12-15 17:31:27 +0000
commit82d9e826ee66db823eb50173e4b85241a670d596 (patch)
tree50cc4a905e80ccd4cf484f6bd4ab851c0d24b47c /devel/p5-Inline-CPP
parent05defced7052a3f92205e0565277ab0d137dfe9a (diff)
downloadports-82d9e826ee66db823eb50173e4b85241a670d596.tar.gz
ports-82d9e826ee66db823eb50173e4b85241a670d596.zip
Notes
Diffstat (limited to 'devel/p5-Inline-CPP')
-rw-r--r--devel/p5-Inline-CPP/Makefile26
-rw-r--r--devel/p5-Inline-CPP/distinfo1
-rw-r--r--devel/p5-Inline-CPP/pkg-comment1
-rw-r--r--devel/p5-Inline-CPP/pkg-descr8
-rw-r--r--devel/p5-Inline-CPP/pkg-plist8
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/p5-Inline-CPP/Makefile b/devel/p5-Inline-CPP/Makefile
new file mode 100644
index 000000000000..8351df997fb1
--- /dev/null
+++ b/devel/p5-Inline-CPP/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Inline::CPP
+# Date created: 14 Dec 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Inline-CPP
+PORTVERSION= 0.23
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Inline
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Inline.pm:${PORTSDIR}/devel/p5-Inline
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= </dev/null
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Inline::CPP.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Inline-CPP/distinfo b/devel/p5-Inline-CPP/distinfo
new file mode 100644
index 000000000000..b052e95dce50
--- /dev/null
+++ b/devel/p5-Inline-CPP/distinfo
@@ -0,0 +1 @@
+MD5 (Inline-CPP-0.23.tar.gz) = 2d7826f5224836f200751fc82ec165de
diff --git a/devel/p5-Inline-CPP/pkg-comment b/devel/p5-Inline-CPP/pkg-comment
new file mode 100644
index 000000000000..a90d6e0827fb
--- /dev/null
+++ b/devel/p5-Inline-CPP/pkg-comment
@@ -0,0 +1 @@
+Write Perl subroutines and classes in C++
diff --git a/devel/p5-Inline-CPP/pkg-descr b/devel/p5-Inline-CPP/pkg-descr
new file mode 100644
index 000000000000..ffa0cddeed5b
--- /dev/null
+++ b/devel/p5-Inline-CPP/pkg-descr
@@ -0,0 +1,8 @@
+The Inline::CPP module allows you to put C++ source code directly
+"inline" in a Perl script or module. You code classes or functions in
+C++, and you can use them as if they were written in Perl.
+
+WWW: http://search.cpan.org/search?dist=Inline-CPP
+
+-- Sergey Skvortsov
+skv@protey.ru
diff --git a/devel/p5-Inline-CPP/pkg-plist b/devel/p5-Inline-CPP/pkg-plist
new file mode 100644
index 000000000000..fdad3b00d09d
--- /dev/null
+++ b/devel/p5-Inline-CPP/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Inline/CPP/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Inline/CPP.pm
+lib/perl5/site_perl/%%PERL_VER%%/Inline/CPP.pod
+lib/perl5/site_perl/%%PERL_VER%%/Inline/CPP/grammar.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Inline/CPP
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Inline/CPP
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Inline 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Inline 2>/dev/null || true